summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/wm.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 957c5a0d5a..44139990b2 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1617,6 +1617,38 @@ modules for building a Wayland compositor.")
(description "Swaylock is a screen locking utility for Wayland compositors.")
(license license:expat))) ; MIT license
+(define-public swaylock-effects
+ ;; Latest release is from November 2020, but doesn't support disabling SSE.
+ (let ((commit "5cb9579faaf5662b111f5722311b701eff1c1d00")
+ (revision "1"))
+ (package
+ (inherit swaylock)
+ (name "swaylock-effects")
+ (version (git-version "1.6-3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mortie/swaylock-effects")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "036dkhfqgk7g9vbr5pxgrs66h5fz0rwdsc67i1w51aa9v01r35ca"))))
+ (arguments
+ `(#:configure-flags '("-Dsse=false")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-meson
+ (lambda _
+ (substitute* "meson.build"
+ (("'-mtune=native',") "")))))))
+ (synopsis "Screen locking utility for Wayland compositors with effects")
+ (description "@code{Swaylock-effects} is a fork of swaylock with additional
+features, such as the ability to take a screenshot as the background image,
+display a clock or apply image manipulation techniques to the background image.")
+ (home-page "https://github.com/mortie/swaylock-effects"))))
+
(define-public swaybg
(package
(name "swaybg")