summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/admin.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 61f287f92c..ee037599a1 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1305,7 +1305,15 @@ tools: server, client, and relay agent.")
("flex" ,flex)))
(arguments
;; There are some tests in testprogs/, but no automated test suite.
- '(#:tests? #f))
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'omit-static-library
+ ;; Neither build nor install libpcap.a.
+ (lambda _
+ (substitute* "Makefile.in"
+ ((" libpcap\\.a") "")
+ ((" install-archive ") " ")))))))
(home-page "https://www.tcpdump.org")
(synopsis "Network packet capture library")
(description