summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/ci.scm1
-rw-r--r--gnu/packages/compression.scm124
-rw-r--r--gnu/packages/libreoffice.scm3
-rw-r--r--gnu/packages/perl-compression.scm154
-rw-r--r--gnu/packages/perl.scm3
6 files changed, 160 insertions, 126 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 499dbed267..e5cc1172cd 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -348,6 +348,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/pem.scm \
%D%/packages/perl.scm \
%D%/packages/perl-check.scm \
+ %D%/packages/perl-compression.scm \
%D%/packages/perl-web.scm \
%D%/packages/photo.scm \
%D%/packages/phabricator.scm \
diff --git a/gnu/packages/ci.scm b/gnu/packages/ci.scm
index 30d86bd09f..bd4a3d3509 100644
--- a/gnu/packages/ci.scm
+++ b/gnu/packages/ci.scm
@@ -36,6 +36,7 @@
#:use-module (gnu packages mail)
#:use-module (gnu packages package-management)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages perl-compression)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages tls)
#:use-module (gnu packages texinfo)
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 19560779bb..8cd90b7452 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -47,7 +47,6 @@
#:use-module (guix git-download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
- #:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages assembly)
@@ -60,7 +59,6 @@
#:use-module (gnu packages file)
#:use-module (gnu packages maths)
#:use-module (gnu packages perl)
- #:use-module (gnu packages perl-check)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages tls)
@@ -710,84 +708,6 @@ sfArk file format to the uncompressed sf2 format.")
decompression of some loosely related file formats used by Microsoft.")
(license license:lgpl2.1+)))
-(define-public perl-compress-raw-bzip2
- (package
- (name "perl-compress-raw-bzip2")
- (version "2.081")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/P/PM/PMQS/"
- "Compress-Raw-Bzip2-" version ".tar.gz"))
- (sha256
- (base32
- "081mpkjy688lg48997fqh3d7ja12vazmz02fw84495civg4vb4l6"))))
- (build-system perl-build-system)
- ;; TODO: Use our bzip2 package.
- (home-page "https://metacpan.org/release/Compress-Raw-Bzip2")
- (synopsis "Low-level interface to bzip2 compression library")
- (description "This module provides a Perl interface to the bzip2
-compression library.")
- (license license:perl-license)))
-
-(define-public perl-compress-raw-zlib
- (package
- (name "perl-compress-raw-zlib")
- (version "2.081")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/P/PM/PMQS/"
- "Compress-Raw-Zlib-" version ".tar.gz"))
- (sha256
- (base32
- "06rsm9ahp20xfyvd3jc69sd0k8vqysryxc6apzdbn96jbcsdwmp1"))))
- (build-system perl-build-system)
- (inputs
- `(("zlib" ,zlib)))
- (arguments
- `(#:phases (modify-phases %standard-phases
- (add-before
- 'configure 'configure-zlib
- (lambda* (#:key inputs #:allow-other-keys)
- (call-with-output-file "config.in"
- (lambda (port)
- (format port "
-BUILD_ZLIB = False
-INCLUDE = ~a/include
-LIB = ~:*~a/lib
-OLD_ZLIB = False
-GZIP_OS_CODE = AUTO_DETECT"
- (assoc-ref inputs "zlib"))))
- #t)))))
- (home-page "https://metacpan.org/release/Compress-Raw-Zlib")
- (synopsis "Low-level interface to zlib compression library")
- (description "This module provides a Perl interface to the zlib
-compression library.")
- (license license:perl-license)))
-
-(define-public perl-io-compress
- (package
- (name "perl-io-compress")
- (version "2.081")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/P/PM/PMQS/"
- "IO-Compress-" version ".tar.gz"))
- (sha256
- (base32
- "1na66ns1g3nni0m9q5494ym4swr21hfgpv88mw8wbj2daiswf4aj"))))
- (build-system perl-build-system)
- (propagated-inputs
- `(("perl-compress-raw-zlib" ,perl-compress-raw-zlib) ; >=2.081
- ("perl-compress-raw-bzip2" ,perl-compress-raw-bzip2))) ; >=2.081
- (home-page "https://metacpan.org/release/IO-Compress")
- (synopsis "IO Interface to compressed files/buffers")
- (description "IO-Compress provides a Perl interface to allow reading and
-writing of compressed data created with the zlib and bzip2 libraries.")
- (license license:perl-license)))
-
(define-public lz4
(package
(name "lz4")
@@ -1762,29 +1682,6 @@ recreates the stored directory structure by default.")
;; files carry the Zlib license; see "docs/copying.html" for details.
(license (list license:lgpl2.0+ license:mpl1.1))))
-(define-public perl-archive-zip
- (package
- (name "perl-archive-zip")
- (version "1.64")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "mirror://cpan/authors/id/P/PH/PHRED/Archive-Zip-"
- version ".tar.gz"))
- (sha256
- (base32
- "0zfinh8nx3rxzscp57vq3w8hihpdb0zs67vvalykcf402kr88pyy"))))
- (build-system perl-build-system)
- (native-inputs
- ;; For tests.
- `(("perl-test-mockmodule" ,perl-test-mockmodule)))
- (synopsis "Provides an interface to Zip archive files")
- (description "The @code{Archive::Zip} module allows a Perl program to
-create, manipulate, read, and write Zip archive files.")
- (home-page "https://metacpan.org/release/Archive-Zip")
- (license license:perl-license)))
-
(define-public libzip
(package
(name "libzip")
@@ -1845,27 +1742,6 @@ to handle the archives, not all commands may be supported for a certain type
of archives.")
(license license:gpl2+)))
-(define-public perl-archive-extract
- (package
- (name "perl-archive-extract")
- (version "0.80")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/B/BI/BINGOS/Archive-Extract-"
- version ".tar.gz"))
- (sha256
- (base32
- "1x15j1q6w6z8hqyqgap0lz4qbq2174wfhksy1fdd653ccbaw5jr5"))))
- (build-system perl-build-system)
- (home-page "https://metacpan.org/release/Archive-Extract")
- (synopsis "Generic archive extracting mechanism")
- (description "It allows you to extract any archive file of the type .tar,
-.tar.gz, .gz, .Z, tar.bz2, .tbz, .bz2, .zip, .xz,, .txz, .tar.xz or .lzma
-without having to worry how it does so, or use different interfaces for each
-type by using either Perl modules, or command-line tools on your system.")
- (license license:perl-license)))
-
(define-public lunzip
(package
(name "lunzip")
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index ccef2c2e9b..25fd07dc8f 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017, 2018, 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
-;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
@@ -70,6 +70,7 @@
#:use-module (gnu packages openldap)
#:use-module (gnu packages pdf)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages perl-compression)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages rdf)
diff --git a/gnu/packages/perl-compression.scm b/gnu/packages/perl-compression.scm
new file mode 100644
index 0000000000..477f686755
--- /dev/null
+++ b/gnu/packages/perl-compression.scm
@@ -0,0 +1,154 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 John Darrington <jmd@gnu.org>
+;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 Petter <petter@mykolab.ch>
+;;; Copyright © 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages perl-compression)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix utils)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system perl)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages perl-check))
+
+(define-public perl-compress-raw-bzip2
+ (package
+ (name "perl-compress-raw-bzip2")
+ (version "2.081")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/P/PM/PMQS/"
+ "Compress-Raw-Bzip2-" version ".tar.gz"))
+ (sha256
+ (base32
+ "081mpkjy688lg48997fqh3d7ja12vazmz02fw84495civg4vb4l6"))))
+ (build-system perl-build-system)
+ ;; TODO: Use our bzip2 package.
+ (home-page "https://metacpan.org/release/Compress-Raw-Bzip2")
+ (synopsis "Low-level interface to bzip2 compression library")
+ (description "This module provides a Perl interface to the bzip2
+compression library.")
+ (license license:perl-license)))
+
+(define-public perl-compress-raw-zlib
+ (package
+ (name "perl-compress-raw-zlib")
+ (version "2.081")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/P/PM/PMQS/"
+ "Compress-Raw-Zlib-" version ".tar.gz"))
+ (sha256
+ (base32
+ "06rsm9ahp20xfyvd3jc69sd0k8vqysryxc6apzdbn96jbcsdwmp1"))))
+ (build-system perl-build-system)
+ (inputs
+ `(("zlib" ,zlib)))
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-before
+ 'configure 'configure-zlib
+ (lambda* (#:key inputs #:allow-other-keys)
+ (call-with-output-file "config.in"
+ (lambda (port)
+ (format port "
+BUILD_ZLIB = False
+INCLUDE = ~a/include
+LIB = ~:*~a/lib
+OLD_ZLIB = False
+GZIP_OS_CODE = AUTO_DETECT"
+ (assoc-ref inputs "zlib"))))
+ #t)))))
+ (home-page "https://metacpan.org/release/Compress-Raw-Zlib")
+ (synopsis "Low-level interface to zlib compression library")
+ (description "This module provides a Perl interface to the zlib
+compression library.")
+ (license license:perl-license)))
+
+(define-public perl-io-compress
+ (package
+ (name "perl-io-compress")
+ (version "2.081")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/P/PM/PMQS/"
+ "IO-Compress-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1na66ns1g3nni0m9q5494ym4swr21hfgpv88mw8wbj2daiswf4aj"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-compress-raw-zlib" ,perl-compress-raw-zlib) ; >=2.081
+ ("perl-compress-raw-bzip2" ,perl-compress-raw-bzip2))) ; >=2.081
+ (home-page "https://metacpan.org/release/IO-Compress")
+ (synopsis "IO Interface to compressed files/buffers")
+ (description "IO-Compress provides a Perl interface to allow reading and
+writing of compressed data created with the zlib and bzip2 libraries.")
+ (license license:perl-license)))
+
+(define-public perl-archive-extract
+ (package
+ (name "perl-archive-extract")
+ (version "0.80")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/B/BI/BINGOS/Archive-Extract-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1x15j1q6w6z8hqyqgap0lz4qbq2174wfhksy1fdd653ccbaw5jr5"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/Archive-Extract")
+ (synopsis "Generic archive extracting mechanism")
+ (description "It allows you to extract any archive file of the type .tar,
+.tar.gz, .gz, .Z, tar.bz2, .tbz, .bz2, .zip, .xz,, .txz, .tar.xz or .lzma
+without having to worry how it does so, or use different interfaces for each
+type by using either Perl modules, or command-line tools on your system.")
+ (license license:perl-license)))
+
+(define-public perl-archive-zip
+ (package
+ (name "perl-archive-zip")
+ (version "1.64")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/P/PH/PHRED/Archive-Zip-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0zfinh8nx3rxzscp57vq3w8hihpdb0zs67vvalykcf402kr88pyy"))))
+ (build-system perl-build-system)
+ (native-inputs
+ ;; For tests.
+ `(("perl-test-mockmodule" ,perl-test-mockmodule)))
+ (synopsis "Provides an interface to Zip archive files")
+ (description "The @code{Archive::Zip} module allows a Perl program to
+create, manipulate, read, and write Zip archive files.")
+ (home-page "https://metacpan.org/release/Archive-Zip")
+ (license license:perl-license)))
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index eca39318a2..5cdb2ed1ea 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016, 2018 Mark H Weaver <mhw@netris.org>
@@ -50,6 +50,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages perl-check)
+ #:use-module (gnu packages perl-compression)
#:use-module (gnu packages perl-web)
#:use-module (gnu packages pkg-config))