summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/disk.scm2
-rw-r--r--gnu/packages/patches/parted-glibc-compat.patch17
3 files changed, 1 insertions, 19 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 0a4ee7c986..912e9c67e3 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1187,7 +1187,6 @@ dist_patch_DATA = \
%D%/packages/patches/p7zip-CVE-2016-9296.patch \
%D%/packages/patches/p7zip-CVE-2017-17969.patch \
%D%/packages/patches/p7zip-remove-unused-code.patch \
- %D%/packages/patches/parted-glibc-compat.patch \
%D%/packages/patches/patchelf-page-size.patch \
%D%/packages/patches/patchelf-rework-for-arm.patch \
%D%/packages/patches/patchutils-test-perms.patch \
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index eb3934155f..c00df73a22 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -83,7 +83,6 @@
(method url-fetch)
(uri (string-append "mirror://gnu/parted/parted-"
version ".tar.xz"))
- (patches (search-patches "parted-glibc-compat.patch"))
(sha256
(base32
"0i1xp367wpqw75b20c3jnism3dg3yqj4a7a22p2jb1h1hyyv9qjp"))))
@@ -105,6 +104,7 @@
(native-inputs
`(("gettext" ,gettext-minimal)
;; For the tests.
+ ("e2fsprogs" ,e2fsprogs)
("perl" ,perl)
("python" ,python-2)))
(home-page "https://www.gnu.org/software/parted/")
diff --git a/gnu/packages/patches/parted-glibc-compat.patch b/gnu/packages/patches/parted-glibc-compat.patch
deleted file mode 100644
index edf4afb0d1..0000000000
--- a/gnu/packages/patches/parted-glibc-compat.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Include <sys/sysmacros.h> for "major" and "minor".
-
-Taken from upstream:
-https://git.savannah.gnu.org/cgit/parted.git/commit/?id=ba5e0451b51c983e40afd123b6e0d3eddb55e610
-
-diff --git a/libparted/arch/linux.c b/libparted/arch/linux.c
-index 31b98ab..7e86b51 100644
---- a/libparted/arch/linux.c
-+++ b/libparted/arch/linux.c
-@@ -41,6 +41,7 @@
- #include <sys/utsname.h> /* for uname() */
- #include <scsi/scsi.h>
- #include <assert.h>
-+#include <sys/sysmacros.h>
- #ifdef ENABLE_DEVICE_MAPPER
- #include <libdevmapper.h>
- #endif