summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/commencement.scm10
-rw-r--r--gnu/packages/shells.scm32
2 files changed, 5 insertions, 37 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index d1ad396916..21a676b394 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -85,7 +85,7 @@
(define %bootstrap-guile+guild
;; This package combines %bootstrap-guile with guild, which is not included
;; in %bootstrap-guile. Guild is needed to build gash-boot and
- ;; gash-core-utils-boot because it is dependency of the Guile build system.
+ ;; gash-utils-boot because it is dependency of the Guile build system.
(package
(name "guile-bootstrap+guild")
(version "2.0")
@@ -221,10 +221,10 @@
(install-file "scripts/bash" bin)
#t))))))))
-(define gash-core-utils-boot
+(define gash-utils-boot
(package
- (inherit gash-core-utils)
- (name "gash-core-utils-boot")
+ (inherit gash-utils)
+ (name "gash-utils-boot")
(version "0.0.214-fc1b")
(source (bootstrap-origin
(origin
@@ -383,7 +383,7 @@
(define (%boot-gash-inputs)
`(("bash" , gash-boot) ; gnu-build-system wants "bash"
- ("coreutils" , gash-core-utils-boot)
+ ("coreutils" , gash-utils-boot)
("guile" ,%bootstrap-guile)
("guile+guild" ,%bootstrap-guile+guild)))
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index a25c15443f..80ef90e111 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -856,35 +856,3 @@ Underpinning these utilities are many Scheme interfaces for manipulating
files and text.")
(license gpl3+)))
-(define-public gash-core-utils
- (package
- (name "gash-core-utils")
- (version "0.0.211-789c3")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://lilypond.org/janneke/guix/20191123/"
- "/gash-core-utils-" version ".tar.gz"))
- (sha256
- (base32
- "1ycf0ivyn9q3lc9hwq8vxg6wkwpsykvh48a5lrzsmganh0ma8wrr"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("pkg-config" ,pkg-config)))
- (inputs
- `(("guile" ,guile-2.2)
- ("gash" ,gash)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-test
- (lambda _
- (substitute* "tests/core-utils.org"
- (("ls \\(GASH\\) UNKNOWN") "ls (GASH) 0.0.211-789c3"))
- #t)))))
- (home-page "https://gitlab.com/janneke/gash-core-utils")
- (synopsis "Bootstrappable replacement of core GNU utilities in Guile Scheme")
- (description "Gash Core Utils provides core GNU utilities in Guile
-Scheme as bootstrappable replacement for GNU coreutils&co.")
- (license gpl3+)))