summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/gcc.scm4
-rw-r--r--gnu/packages/patches/gcc-5.0-libvtv-runpath.patch15
3 files changed, 19 insertions, 1 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 95eefdcbf5..3223dc8afd 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -422,6 +422,7 @@ dist_patch_DATA = \
gnu/packages/patches/gcc-arm-link-spec-fix.patch \
gnu/packages/patches/gcc-cross-environment-variables.patch \
gnu/packages/patches/gcc-libvtv-runpath.patch \
+ gnu/packages/patches/gcc-5.0-libvtv-runpath.patch \
gnu/packages/patches/geoclue-config.patch \
gnu/packages/patches/ghostscript-runpath.patch \
gnu/packages/patches/gitolite-openssh-6.8-compat.patch \
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 957917bf0b..4512e54e8b 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -343,7 +343,9 @@ Go. It also includes runtime support libraries for these languages.")
(sha256
(base32
"1bd5vj4px3s8nlakbgrh38ynxq4s654m6nxz7lrj03mvkkwgvnmp"))
- (patches (origin-patches (package-source gcc-4.9)))))))
+ (patches (map search-patch
+ '("gcc-arm-link-spec-fix.patch"
+ "gcc-5.0-libvtv-runpath.patch")))))))
(define* (custom-gcc gcc name languages #:key (separate-lib-output? #t))
"Return a custom version of GCC that supports LANGUAGES."
diff --git a/gnu/packages/patches/gcc-5.0-libvtv-runpath.patch b/gnu/packages/patches/gcc-5.0-libvtv-runpath.patch
new file mode 100644
index 0000000000..9a9bc5ca53
--- /dev/null
+++ b/gnu/packages/patches/gcc-5.0-libvtv-runpath.patch
@@ -0,0 +1,15 @@
+GCC 4.9 and later have libvtv and, just like libstdc++ (see
+https://gcc.gnu.org/bugzilla/show_bug.cgi?id=32354), it doesn't
+have $libdir in its RUNPATH, but it NEEDs libgcc_s. This patch
+fixes that.
+
+--- gcc-5.1.0/libvtv/Makefile.in 2014-10-30 09:28:58.000000000 +0100
++++ gcc-5.1.0/libvtv/Makefile.in 2015-04-30 09:51:04.161129705 +0200
+@@ -15,6 +15,7 @@
+
+ @SET_MAKE@
+
++libvtv_la_LDFLAGS = -Wl,-rpath=$(libdir)
+
+ VPATH = @srcdir@
+ pkgdatadir = $(datadir)/@PACKAGE@