summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/boost.scm11
1 files changed, 1 insertions, 10 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index d8ce30cd88..d00f96de64 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -68,16 +68,7 @@
;; Set the RUNPATH to $libdir so that the libs find each other.
(string-append "linkflags=-Wl,-rpath="
- (assoc-ref %outputs "out") "/lib")
-
- ;; Boost's 'context' library is not yet supported on mips64, so
- ;; we disable it. The 'coroutine' library depends on 'context',
- ;; so we disable that too.
- ,@(if (string-prefix? "mips64" (or (%current-target-system)
- (%current-system)))
- '("--without-context"
- "--without-coroutine" "--without-coroutine2")
- '()))
+ (assoc-ref %outputs "out") "/lib"))
#:phases
(modify-phases %standard-phases
(delete 'bootstrap)