summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/machine-learning.scm3
-rw-r--r--gnu/packages/python-xyz.scm13
2 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index ace52b4c9d..e3c69948e2 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1604,6 +1604,9 @@ INSTALL_RPATH " (assoc-ref outputs "out") "/lib)\n")))
("protobuf:native" ,protobuf-next) ; protoc
("protobuf:src" ,(package-source protobuf-next))
("eigen:src" ,(package-source eigen-for-tensorflow))
+ ;; install_pip_packages.sh wants setuptools 39.1.0 specifically.
+ ("python-setuptools" ,python-setuptools-for-tensorflow)
+
;; The commit hashes and URLs for third-party source code are taken
;; from "tensorflow/workspace.bzl".
("boringssl-src"
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 65dffd33bf..6796f1c065 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -713,6 +713,19 @@ Python 3 support.")
(define-public python2-setuptools
(package-with-python2 python-setuptools))
+;; The setuptools provided by Python 3.7.4 is too new for Tensorflow.
+(define-public python-setuptools-for-tensorflow
+ (hidden-package
+ (package
+ (inherit python-setuptools)
+ (version "39.1.0")
+ (source (origin
+ (inherit (package-source python-setuptools))
+ (uri (pypi-uri "setuptools" version ".zip"))
+ (sha256
+ (base32
+ "1mzdhvfhnv4lggxa8rjl0dzqxvfx377gg5sqs57v89wrp09lwj65")))))))
+
(define-public python-uniseg
(package
(name "python-uniseg")