summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gnome.scm22
-rw-r--r--gnu/packages/linux.scm2
-rw-r--r--gnu/packages/mate.scm2
-rw-r--r--gnu/packages/package-management.scm4
4 files changed, 3 insertions, 27 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e8c26f5370..e2ecc1bb6a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -223,7 +223,6 @@
("libnotify" ,libnotify)
("libsm" ,libsm)
("libxml2" ,libxml2)
- ("nettle" ,nettle)
("totem-pl-parser" ,totem-pl-parser)))
(home-page "https://projects.gnome.org/brasero/")
(synopsis "CD/DVD burning tool for Gnome")
@@ -428,8 +427,7 @@ access the common Google services, and has full asynchronous support.")
`(("gtk+" ,gtk+)
("libjpeg" ,libjpeg-turbo)
("lcms" ,lcms)
- ("libtiff" ,libtiff)
- ("nettle" ,nettle)))
+ ("libtiff" ,libtiff)))
(propagated-inputs
;; In Requires of libgxps.pc.
`(("cairo" ,cairo)
@@ -818,10 +816,6 @@ forgotten when the session ends.")
("libcanberra" ,libcanberra)
("libsecret" ,libsecret)
- ;; XXX: 'libarchive.pc' adds '-lnettle' so Nettle should really be
- ;; propagated from there.
- ("nettle" ,nettle)
-
;; For tests.
("dogtail" ,python2-dogtail)))
(native-inputs
@@ -3332,8 +3326,7 @@ settings, themes, mouse settings, and startup of other daemons.")
("libgcrypt" ,libgcrypt)
("libxml2" ,libxml2)))
(inputs
- `(("nettle" ,nettle)
- ("libsoup" ,libsoup)))
+ `(("libsoup" ,libsoup)))
(home-page "https://projects.gnome.org/totem")
(synopsis "Library to parse and save media playlists for GNOME")
(description "Totem-pl-parser is a GObjects-based library to parse and save
@@ -3788,7 +3781,6 @@ as possible!")
("libxml2" ,libxml2)
("liboauth" ,liboauth)
("libsoup" ,libsoup)
- ("nettle" ,nettle)
("totem-pl-parser" ,totem-pl-parser)))
(arguments
`(#:phases
@@ -3837,7 +3829,6 @@ for application developers.")
("pkg-config" ,pkg-config)))
(inputs
`(("grilo" ,grilo)
- ("nettle" ,nettle) ; XXX: required by libgrlpls-0.3.la
("glib" ,glib)
("libxml2" ,libxml2)
("sqlite" ,sqlite)
@@ -3926,7 +3917,6 @@ for application developers.")
("totem-pl-parser" ,totem-pl-parser)
("grilo" ,grilo)
("grilo-plugins" ,grilo-plugins)
- ("nettle" ,nettle)
("vala" ,vala)))
(arguments
`(#:glib-or-gtk? #t
@@ -4028,7 +4018,6 @@ which can read a large number of file formats.")
("python-pygobject" ,python2-pygobject)
("vala" ,vala)
("gmime" ,gmime)
- ("nettle" ,nettle)
("adwaita-icon-theme" ,adwaita-icon-theme)
("grilo" ,grilo)
("grilo-plugins" ,grilo-plugins)
@@ -4244,7 +4233,6 @@ part of udev-extras, then udev, then systemd. It's now a project on its own.")
("libsmbclient" ,samba)
("libsoup" ,libsoup)
("libxml2" ,libxml2)
- ("nettle" ,nettle) ; XXX: required by libarchive.pc
("openssh" ,openssh)
("polkit" ,polkit)
("udisks" ,udisks)))
@@ -4760,7 +4748,6 @@ share them with others via social networking and more.")
("json-glib" ,json-glib)
("libarchive" ,libarchive)
("libnotify" ,libnotify)
- ("nettle" ,nettle)
("itstool" ,itstool)
("libxml2" ,libxml2)))
(synopsis "Graphical archive manager for GNOME")
@@ -6217,8 +6204,7 @@ as SASL, TLS and VeNCrypt. Additionally it supports encoding extensions.")
(propagated-inputs
`(("libarchive" ,libarchive))) ; XXX document why
(inputs
- `(("gtk+" ,gtk+)
- ("nettle" ,nettle))) ; XXX: required by libarchive.pc
+ `(("gtk+" ,gtk+)))
(synopsis "Archives integration support for GNOME")
(home-page "https://git.gnome.org/browse/gnome-autoar/")
(description
@@ -6286,7 +6272,6 @@ easy, safe, and automatic.")
("gstreamer" ,gstreamer)
("gst-plugins-base" ,gst-plugins-base)
("sqlite" ,sqlite)
- ("nettle" ,nettle) ; XXX why is this needed?
("python" ,python)
("poppler" ,poppler)
("libgsf" ,libgsf)
@@ -6355,7 +6340,6 @@ shared object databases, search tools and indexing.")
("gnome-autoar" ,gnome-autoar)
("libseccomp" ,libseccomp)
("libselinux" ,libselinux)
- ("nettle" ,nettle) ; XXX required by libarchive.pc via gnome-autoar
("tracker" ,tracker)
;; XXX: gtk+ is required by libnautilus-extension.pc
;;
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8b7a31d110..998f197304 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -90,7 +90,6 @@
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages netpbm)
- #:use-module (gnu packages nettle)
#:use-module (gnu packages networking)
#:use-module (gnu packages ninja)
#:use-module (gnu packages nss)
@@ -3182,7 +3181,6 @@ thanks to the use of namespaces.")
(inputs
`(("libarchive" ,libarchive)
("python" ,python-wrapper)
- ("nettle" ,nettle)
("zlib" ,zlib)
("squashfs-tools" ,squashfs-tools)))
(home-page "https://singularity.lbl.gov/")
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 9e9fda0929..ba90ccec73 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -56,7 +56,6 @@
#:use-module (gnu packages libcanberra)
#:use-module (gnu packages linux)
#:use-module (gnu packages messaging)
- #:use-module (gnu packages nettle)
#:use-module (gnu packages nss)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pdf)
@@ -819,7 +818,6 @@ infamous 'Wanda the Fish'.")
("libgnome-keyring" ,libgnome-keyring)
("libarchive" ,libarchive)
("marco" ,marco)
- ("nettle" ,nettle)
("openjpeg" ,openjpeg-1)
("pango" ,pango)
;;("texlive" ,texlive)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index b641340a1a..84bb3542f1 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -58,7 +58,6 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages lisp)
#:use-module (gnu packages man)
- #:use-module (gnu packages nettle)
#:use-module (gnu packages nss)
#:use-module (gnu packages patchutils)
#:use-module (gnu packages perl)
@@ -542,7 +541,6 @@ symlinks to the files in a common directory such as /usr/local.")
("nss" ,nss)
("nspr" ,nspr)
("libarchive" ,libarchive)
- ("nettle" ,nettle) ;XXX: actually a dependency of libarchive
("file" ,file)
("bzip2" ,bzip2)
("zlib" ,zlib)
@@ -1012,7 +1010,6 @@ for packaging and deployment of cross-compiled Windows applications.")
("gpgme" ,gpgme)
("libarchive" ,libarchive)
("libsoup" ,libsoup)
- ("nettle" ,nettle) ; required by 'libarchive.la'
("util-linux" ,util-linux)))
(home-page "https://ostree.readthedocs.io/en/latest/")
(synopsis "Operating system and container binary deployment and upgrades")
@@ -1071,7 +1068,6 @@ the boot loader configuration.")
("libsoup" ,libsoup)
("libxau" ,libxau)
("libxml2" ,libxml2)
- ("nettle" ,nettle)
("util-linux" ,util-linux)))
(home-page "https://flatpak.org")
(synopsis "System for building, distributing, and running sandboxed desktop