summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 57a06f836b..aa8ab70d2d 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -38,6 +38,7 @@
;;; Copyright © 2023 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2023 Jake Leporte <jakeleporte@outlook.com>
;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3926,6 +3927,27 @@ operators for a given class (or object), including where in the inheritance
hierarchy the overloads are declared and where the code implementing it is.")
(license (package-license perl))))
+(define-public perl-devel-nytprof
+ (package
+ (name "perl-devel-nytprof")
+ (version "6.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/J/JK/JKEENAN/Devel-NYTProf-" version
+ ".tar.gz"))
+ (sha256
+ (base32 "00wfmllpm8fgr2r4rm5a8dvkd12ljg51bz6fpsb7c95jlmyxs95c"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-capture-tiny perl-sub-name perl-test-differences))
+ (propagated-inputs (list perl-file-which perl-json-maybexs))
+ (home-page "https://metacpan.org/release/Devel-NYTProf")
+ (synopsis "Powerful fast feature-rich Perl source code profiler")
+ (description "@code{Devel::NYTProf} is a powerful, fast and feature-rich
+Perl source code profiler.")
+ (license (package-license perl))))
+
(define-public perl-devel-partialdump
(package
(name "perl-devel-partialdump")