summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index eed2f4b71c..df34da9200 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3196,6 +3196,33 @@ environment set through Direnv.")
that the binary uses instead of the actual binary contents.")
(license license:gpl3+)))
+(define-public emacs-font-lock-studio
+ (package
+ (name "emacs-font-lock-studio")
+ (version "20170127.2051") ;melpa version
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Lindydancer/font-lock-studio")
+ (commit "12c35967b31233e06946c70627aa3152dacfe261")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0q0s6f5vi3sfifj7vq2nnsmgyyivp1sd3idk32858md5ri71qif0"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/Lindydancer/font-lock-studio")
+ (synopsis "Interactive debugger for Font Lock keywords")
+ (description
+ "Font Lock Studio is an interactive debugger for Emacs syntax highlighting
+rules, also called Font Lock keywords. It can @emph{single-step} Font Lock
+keywords -- matchers, highlights, and anchored rules, to see what happens when
+a buffer is fontified. Breakpoints can be set on or inside rules. When
+inside a rule, matches are visualized using a palette of background colors.
+The explainer can describe a rule in plain-text English. Finally, tight
+integration with Edebug allows stepping into Lisp expressions that are part of
+the Font Lock keywords.")
+ (license license:gpl3+)))
+
(define-public emacs-form-feed
(package
(name "emacs-form-feed")