summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/package-management.scm40
1 files changed, 23 insertions, 17 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 908efee821..579abb063f 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -80,6 +80,7 @@
#:use-module (gnu packages libedit)
#:use-module (gnu packages linux)
#:use-module (gnu packages lisp)
+ #:use-module (gnu packages lua)
#:use-module (gnu packages man)
#:use-module (gnu packages markup)
#:use-module (gnu packages nettle)
@@ -825,7 +826,7 @@ features of Stow with some extensions.")
(define-public rpm
(package
(name "rpm")
- (version "4.16.1.3")
+ (version "4.17.0")
(source (origin
(method url-fetch)
(uri (string-append "http://ftp.rpm.org/releases/rpm-"
@@ -833,35 +834,40 @@ features of Stow with some extensions.")
version ".tar.bz2"))
(sha256
(base32
- "07g2g0adgjm29wqy94iqhpp5dk0hacfw1yf7kzycrrxnfbwwfgai"))))
+ "0sjyqs6hc57k46f45b68dfxnp985s0gar0fi1s0ig6vl4h5j439f"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--with-external-db" ;use the system's bdb
- "--enable-python"
- "--without-lua")
+ '(#:configure-flags '("--with-external-db" ;use the system's bdb
+ "--enable-python")
#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'fix-lua-check
+ (lambda _
+ (substitute* "configure"
+ (("lua >= 5.3")
+ "lua-5.3 >= 5.3"))))
(add-before 'configure 'set-nss-library-path
(lambda* (#:key inputs #:allow-other-keys)
(let ((nss (assoc-ref inputs "nss")))
(setenv "LIBRARY_PATH"
(string-append (getenv "LIBRARY_PATH") ":"
- nss "/lib/nss"))
- #t))))))
+ nss "/lib/nss"))))))))
(native-inputs
(list pkg-config))
(inputs
- (list python
- xz
- bdb
- popt
- nss
- nspr
+ (list bdb
+ bzip2
+ cpio
+ file
libarchive
libgcrypt
- file
- bzip2
- zlib
- cpio))
+ lua
+ nspr
+ nss
+ popt
+ python
+ sqlite
+ xz
+ zlib))
(home-page "https://rpm.org/")
(synopsis "The RPM Package Manager")
(description