summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2020-12-05 10:27:55 -0500
committer宋文武 <iyzsong@member.fsf.org>2021-02-12 15:11:36 +0800
commitdb6b9d2f4bc59511904e8c1412d0257675c46095 (patch)
treebb14d07667f3ae3065cb48b30a64ce8c5059ed44 /tests
parent8458d8db70885b350285e8b1490734349135e51e (diff)
downloadguix-patches-db6b9d2f4bc59511904e8c1412d0257675c46095.tar
guix-patches-db6b9d2f4bc59511904e8c1412d0257675c46095.tar.gz
services: Add transmission-daemon service.
* gnu/services/file-sharing.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * po/packages/POTFILES.in: Add it. * tests/services/file-sharing.scm: New file. * Makefile.am (SCM_TESTS): Add it. * doc/guix.texi (File-Sharing Services): New section. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'tests')
-rw-r--r--tests/services/file-sharing.scm59
1 files changed, 59 insertions, 0 deletions
diff --git a/tests/services/file-sharing.scm b/tests/services/file-sharing.scm
new file mode 100644
index 0000000000..27bec57325
--- /dev/null
+++ b/tests/services/file-sharing.scm
@@ -0,0 +1,59 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Simon South <simon@simonsouth.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (tests services file-sharing)
+ #:use-module (gnu services file-sharing)
+ #:use-module (srfi srfi-64))
+
+;;; Tests for the (gnu services file-sharing) module.
+
+(test-begin "file-sharing")
+
+
+;;;
+;;; Transmission Daemon.
+;;;
+
+(define %transmission-salt-length 8)
+
+(define (valid-transmission-salt? salt)
+ (and (string? salt)
+ (eqv? (string-length salt) %transmission-salt-length)))
+
+(test-assert "transmission-random-salt"
+ (valid-transmission-salt? (transmission-random-salt)))
+
+(test-equal "transmission-password-hash, typical values"
+ "{ef6fba106cdef3aac64d1410090cae353cbecde53ceVVQO2"
+ (transmission-password-hash "transmission" "3ceVVQO2"))
+
+(test-equal "transmission-password-hash, empty password"
+ "{820f816515d8969d058d07a1de018650619ee7ffCp.I5SWg"
+ (transmission-password-hash "" "Cp.I5SWg"))
+
+(test-error "transmission-password-hash, salt value too short"
+ (transmission-password-hash
+ "transmission"
+ (make-string (- %transmission-salt-length 1) #\a)))
+
+(test-error "transmission-password-hash, salt value too long"
+ (transmission-password-hash
+ "transmission"
+ (make-string (+ %transmission-salt-length 1) #\a)))
+
+(test-end "file-sharing")