summaryrefslogtreecommitdiff
path: root/tests/store-roots.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-04-06 22:27:57 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-10 17:09:47 +0200
commit72eda0624be89ed18302fd7d7f22976071ab020c (patch)
tree8ce31092c5a3710dab305116d18d5829b50487a0 /tests/store-roots.scm
parent08d0f950b3ad936b859064c070be16548684cbd1 (diff)
downloadguix-patches-72eda0624be89ed18302fd7d7f22976071ab020c.tar
guix-patches-72eda0624be89ed18302fd7d7f22976071ab020c.tar.gz
Add (guix store roots).
* guix/store/roots.scm, tests/store-roots.scm: New files. * Makefile.am (STORE_MODULES): Add guix/store/roots.scm. (SCM_TESTS): Add tests/store-roots.scm.
Diffstat (limited to 'tests/store-roots.scm')
-rw-r--r--tests/store-roots.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/tests/store-roots.scm b/tests/store-roots.scm
new file mode 100644
index 0000000000..5bcf1bc87e
--- /dev/null
+++ b/tests/store-roots.scm
@@ -0,0 +1,53 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (test-store-deduplication)
+ #:use-module (guix tests)
+ #:use-module (guix store)
+ #:use-module (guix store roots)
+ #:use-module ((guix utils) #:select (call-with-temporary-directory))
+ #:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-64))
+
+(define %store
+ (open-connection))
+
+(test-begin "store-roots")
+
+(test-assert "gc-roots, regular root"
+ (let* ((item (add-text-to-store %store "something"
+ (random-text)))
+ (root (string-append %gc-roots-directory "/test-gc-root")))
+ (symlink item root)
+ (let ((result (member root (gc-roots))))
+ (delete-file root)
+ result)))
+
+(test-assert "gc-roots, indirect root"
+ (call-with-temporary-directory
+ (lambda (directory)
+ (let* ((item (add-text-to-store %store "something"
+ (random-text)))
+ (root (string-append directory "/gc-root")))
+ (symlink item root)
+ (add-indirect-root %store root)
+ (let ((result (member root (gc-roots))))
+ (delete-file root)
+ result)))))
+
+(test-end "store-roots")