summaryrefslogtreecommitdiff
path: root/tests/search-paths.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-06-14 21:53:25 +0200
committerLudovic Courtès <ludo@gnu.org>2019-06-14 22:09:38 +0200
commit92d00ca4661e186022732a47956a2bc0ef16be96 (patch)
tree048f65570b56a062cfe1e183d75c595c80cb7816 /tests/search-paths.scm
parent1ba0b1e6ec41afd94a3c5f907b1122204dcb5d9d (diff)
downloadguix-patches-92d00ca4661e186022732a47956a2bc0ef16be96.tar
guix-patches-92d00ca4661e186022732a47956a2bc0ef16be96.tar.gz
build: Remove 'gnu/packages/bootstrap' and its binaries.
* gnu/local.mk (bootstrapdir, bootstrap_i686_linuxdir) (bootstrap_armhf_linuxdir, bootstrap_aarch64_linuxdir) (bootstrap_mips64el_linuxdir, dist_bootstrap_i686_linux_DATA) (dist_bootstrap_armhf_linux_DATA, dist_bootstrap_aarch64_linux_DATA) (dist_bootstrap_mips64el_linux_DATA): Remove. (set-bootstrap-executable-permissions): Remove target. * Makefile.am (install-data-hook): Remove dependency on 'set-bootstrap-executable-permissions'. * gnu/packages/bootstrap: Remove directory. * tests/search-paths.scm ("evaluate-search-paths, separator is #f"): Adjust to match .../aux-files/linux-libre.
Diffstat (limited to 'tests/search-paths.scm')
-rw-r--r--tests/search-paths.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/tests/search-paths.scm b/tests/search-paths.scm
index 8dad424415..767a80b76c 100644
--- a/tests/search-paths.scm
+++ b/tests/search-paths.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2017, 2019 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29,17 +29,17 @@
(test-equal "evaluate-search-paths, separator is #f"
(string-append %top-srcdir
- "/gnu/packages/bootstrap/aarch64-linux")
+ "/gnu/packages/aux-files/linux-libre")
;; The following search path spec should evaluate to a single item: the
;; first directory that matches the "-linux$" pattern in
;; gnu/packages/bootstrap.
(let ((spec (search-path-specification
(variable "CHBOUIB")
- (files '("gnu/packages/bootstrap"))
+ (files '("gnu/packages/aux-files"))
(file-type 'directory)
(separator #f)
- (file-pattern "-linux$"))))
+ (file-pattern "^linux"))))
(match (evaluate-search-paths (list spec)
(list %top-srcdir))
(((spec* . value))