summaryrefslogtreecommitdiff
path: root/tests/scripts-build.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-01-31 20:18:52 +0100
committerLudovic Courtès <ludo@gnu.org>2016-02-01 08:59:13 +0100
commit629a064f3244e8cd13114842969de7e3b6b02f46 (patch)
tree8886fc34606f4fe3d78bbbd42eea68d5e53e4c7c /tests/scripts-build.scm
parentefdcb6f29cd0fd384ed88b0b9eb65547514a79a5 (diff)
downloadguix-patches-629a064f3244e8cd13114842969de7e3b6b02f46.tar
guix-patches-629a064f3244e8cd13114842969de7e3b6b02f46.tar.gz
guix build: Transformations operate on single objects.
* guix/scripts/build.scm (transform-package-source): Return a procedure that expects a single object rather than a list of packages. (options->transformation): Rewrite to precompute the list of applicable transformations and to return a procedure that expects a single object rather than a list of objects. (options->derivations): Adjust accordingly. * tests/scripts-build.scm: New file. * Makefile.am (SCM_TESTS): Add it.
Diffstat (limited to 'tests/scripts-build.scm')
-rw-r--r--tests/scripts-build.scm65
1 files changed, 65 insertions, 0 deletions
diff --git a/tests/scripts-build.scm b/tests/scripts-build.scm
new file mode 100644
index 0000000000..75dc119e88
--- /dev/null
+++ b/tests/scripts-build.scm
@@ -0,0 +1,65 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (test-scripts-build)
+ #:use-module (guix tests)
+ #:use-module (guix store)
+ #:use-module (guix packages)
+ #:use-module (guix scripts build)
+ #:use-module (guix ui)
+ #:use-module (srfi srfi-64))
+
+
+(test-begin "scripts-build")
+
+(test-assert "options->transformation, no transformations"
+ (let ((p (dummy-package "foo"))
+ (t (options->transformation '())))
+ (with-store store
+ (eq? (t store p) p))))
+
+(test-assert "options->transformation, with-source"
+ ;; Our pseudo-package is called 'guix.scm' so the 'guix.scm' source should
+ ;; be applicable.
+ (let* ((p (dummy-package "guix.scm"))
+ (s (search-path %load-path "guix.scm"))
+ (t (options->transformation `((with-source . ,s)))))
+ (with-store store
+ (let ((new (t store p)))
+ (and (not (eq? new p))
+ (string=? (package-source new)
+ (add-to-store store "guix.scm" #t
+ "sha256" s)))))))
+
+(test-assert "options->transformation, with-source, no matches"
+ ;; When a transformation in not applicable, a warning must be raised.
+ (let* ((p (dummy-package "foobar"))
+ (s (search-path %load-path "guix.scm"))
+ (t (options->transformation `((with-source . ,s)))))
+ (with-store store
+ (let* ((port (open-output-string))
+ (new (parameterize ((guix-warning-port port))
+ (t store p))))
+ (and (eq? new p)
+ (string-contains (get-output-string port)
+ "had no effect"))))))
+
+(test-end)
+
+
+(exit (= (test-runner-fail-count (test-runner-current)) 0))