summaryrefslogtreecommitdiff
path: root/tests/guix-daemon.sh
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-12-06 00:03:26 +0100
committerLudovic Courtès <ludo@gnu.org>2012-12-06 00:07:08 +0100
commit69cfce50dbb2000c5f5d98f0f364fe324004bf99 (patch)
treeceb925ad7fa3f30b88c6074a071a229a31f769eb /tests/guix-daemon.sh
parentb980f0f9fd6f926f2a1130f77bd3cdb70e741429 (diff)
downloadguix-patches-69cfce50dbb2000c5f5d98f0f364fe324004bf99.tar
guix-patches-69cfce50dbb2000c5f5d98f0f364fe324004bf99.tar.gz
build: Run all the tests against the just-built daemon.
* test-env.in: New file. * configure.ac: Add it to `AC_CONFIG_FILES' and `commands-exec'. * config-daemon.ac: Set and substitute `GUIX_TEST_ROOT'. * Makefile.am (SCM_LOG_COMPILER, SH_LOG_COMPILER): Use it in lieu of `pre-inst-env'. * daemon.am (test_root): Remove (AM_TESTS_ENVIRONMENT): Remove `TEST_ROOT'. (clean-local): Use $(GUIX_TEST_ROOT); make files writable before removing them.guix_test_root * tests/guix-daemon.sh: Remove `NIX_' variable settings; don't launch `guix-daemon'.
Diffstat (limited to 'tests/guix-daemon.sh')
-rw-r--r--tests/guix-daemon.sh19
1 files changed, 0 insertions, 19 deletions
diff --git a/tests/guix-daemon.sh b/tests/guix-daemon.sh
index b6b92a78d4..b942cbd546 100644
--- a/tests/guix-daemon.sh
+++ b/tests/guix-daemon.sh
@@ -22,27 +22,8 @@
set -e
-NIX_SUBSTITUTERS="" # don't resort to substituters
-NIX_IGNORE_SYMLINK_STORE=1 # in case the store is a symlink
-NIX_STORE_DIR="$TEST_ROOT/store"
-NIX_LOCALSTATE_DIR="$TEST_ROOT/var"
-NIX_LOG_DIR="$TEST_ROOT/var/log/nix"
-NIX_STATE_DIR="$TEST_ROOT/var/nix"
-NIX_DB_DIR="$TEST_ROOT/db"
-NIX_ROOT_FINDER="$top_builddir/nix/scripts/list-runtime-roots"
-export NIX_SUBSTITUTERS NIX_IGNORE_SYMLINK_STORE NIX_STORE_DIR \
- NIX_LOCALSTATE_DIR NIX_LOG_DIR NIX_STATE_DIR NIX_DB_DIR \
- NIX_ROOT_FINDER
-
guix-daemon --version
guix-build --version
-# Launch the daemon without chroot support because is may be
-# unavailable, for instance if we're not running as root.
-guix-daemon --disable-chroot &
-
-daemon_pid=$!
-trap "kill $daemon_pid" EXIT
-
guix-build -e '(@ (distro packages bootstrap) %bootstrap-guile)'
guix-build coreutils -n