summaryrefslogtreecommitdiff
path: root/guix
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2021-03-30 01:27:43 -0400
committerJelle Licht <jlicht@fsfe.org>2021-04-02 18:04:24 +0200
commitf6c43c932a39bfa73a9750daadcd20f505ddc939 (patch)
treed915cb04b3558b94255c14c779a2030bfdf9d07c /guix
parent31c4d89073bdbe2b807ccf7b172df6db200f8d32 (diff)
downloadguix-patches-f6c43c932a39bfa73a9750daadcd20f505ddc939.tar
guix-patches-f6c43c932a39bfa73a9750daadcd20f505ddc939.tar.gz
gnu: Add node-lts.
* gnu/packages/node.scm (node-lts): New variable. * guix/build-system/node.scm (default-node): Use it.
Diffstat (limited to 'guix')
-rw-r--r--guix/build-system/node.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/guix/build-system/node.scm b/guix/build-system/node.scm
index 4991ed53a5..98f63f87ef 100644
--- a/guix/build-system/node.scm
+++ b/guix/build-system/node.scm
@@ -39,7 +39,7 @@
"Return the default Node package."
;; Lazily resolve the binding to avoid a circular dependency.
(let ((node (resolve-interface '(gnu packages node))))
- (module-ref node 'node)))
+ (module-ref node 'node-lts)))
(define* (lower name
#:key source inputs native-inputs outputs system target