summaryrefslogtreecommitdiff
path: root/guix
diff options
context:
space:
mode:
authorJohn Darrington <john@darrington.wattle.id.au>2013-12-17 20:33:26 +0100
committerLudovic Courtès <ludo@gnu.org>2013-12-17 21:28:07 +0100
commitdb6190899ea15d3b66d6b2d82bdeaee442423100 (patch)
tree84ca4ed404ea6fdb6c127d940f9cb73f2c8431b8 /guix
parentf22e0e264e400b69fc91509c676f9069b7cdbc2e (diff)
downloadguix-patches-db6190899ea15d3b66d6b2d82bdeaee442423100.tar
guix-patches-db6190899ea15d3b66d6b2d82bdeaee442423100.tar.gz
gnu: gnu-build-system: Add CC_FOR_BUILD to configure flags.
* guix/build/gnu-build-system.scm: Add new configure flag: CC_FOR_BUILD=gcc * gnu/packages/gnupg.scm, gnu/packages/guile.scm, gnu/packages/make-bootstrap.scm: remove CC_FOR_BUILD from these package descriptions. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'guix')
-rw-r--r--guix/build/gnu-build-system.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/guix/build/gnu-build-system.scm b/guix/build/gnu-build-system.scm
index 65c9fcd1bd..6d26392c8f 100644
--- a/guix/build/gnu-build-system.scm
+++ b/guix/build/gnu-build-system.scm
@@ -136,7 +136,10 @@ makefiles."
(bash (or (and=> (assoc-ref (or native-inputs inputs) "bash")
(cut string-append <> "/bin/bash"))
"/bin/sh"))
- (flags `(,(string-append "CONFIG_SHELL=" bash)
+ (flags `(,@(if target ; cross building
+ '("CC_FOR_BUILD=gcc")
+ '())
+ ,(string-append "CONFIG_SHELL=" bash)
,(string-append "SHELL=" bash)
,(string-append "--prefix=" prefix)
"--enable-fast-install" ; when using Libtool