summaryrefslogtreecommitdiff
path: root/guix
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-24 19:31:39 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-25 04:42:16 +0200
commit52beae7b8a33717259895add631b8ae71e958e0e (patch)
tree5fbc7023b4e065098b8c16be875985c4cab6d57e /guix
parent7ecd1761a236a2256e420032d561aa6c372d95a8 (diff)
downloadguix-patches-52beae7b8a33717259895add631b8ae71e958e0e.tar
guix-patches-52beae7b8a33717259895add631b8ae71e958e0e.tar.gz
gnu, guix: Yearly ritual purging of the filesystems.
* gnu/packages/android.scm (android-ext4-utils)[synopsis]: Fix ‘file system’ spelling. * gnu/packages/disk.scm (rmlint)[synopsis, description]: Likewise. * gnu/packages/golang.scm (go-github-com-kr-fs)[synopsis, description]: Likewise & edit for grammar. * gnu/packages/ipfs.scm (gx, go-ipfs)[description]: Likewise. * /gnu/packages/java.scm (java-commons-vfs)[synopsis]: Likewise. * gnu/packages/linux.scm (fuseiso)[description]: Likewise. (genext2fs)[synopsis, description]: Likewise. * gnu/packages/package-management.scm (libostree)[description]: Likewise. * gnu/packages/python-xyz.scm (python-requests-file)[description]: Likewise & mark up. * gnu/packages/rails.scm (ruby-with-advisory-lock)[description]: Likewise. * gnu/packages/ruby.scm (ruby-rerun)[description]: Likewise. * guix/build/go-build-system.scm (setup-go-environment)<docstring>: Likewise. * guix/store/deduplication.scm (get-temp-link)<docstring>: Likewise.
Diffstat (limited to 'guix')
-rw-r--r--guix/build/go-build-system.scm4
-rw-r--r--guix/store/deduplication.scm4
2 files changed, 4 insertions, 4 deletions
diff --git a/guix/build/go-build-system.scm b/guix/build/go-build-system.scm
index 1a716cea77..282df19f24 100644
--- a/guix/build/go-build-system.scm
+++ b/guix/build/go-build-system.scm
@@ -42,7 +42,7 @@
;; structure called a 'workspace' [1]. This workspace can be found by Go via
;; the GOPATH environment variable. Typically, all Go source code and compiled
;; objects are kept in a single workspace, but GOPATH may be a list of
-;; directories [2]. In this go-build-system we create a filesystem union of
+;; directories [2]. In this go-build-system we create a file system union of
;; the Go-language dependencies. Previously, we made GOPATH a list of store
;; directories, but stopped because Go programs started keeping references to
;; these directories in Go 1.11:
@@ -127,7 +127,7 @@
;; Code:
(define* (setup-go-environment #:key inputs outputs #:allow-other-keys)
- "Prepare a Go build environment for INPUTS and OUTPUTS. Build a filesystem
+ "Prepare a Go build environment for INPUTS and OUTPUTS. Build a file system
union of INPUTS. Export GOPATH, which helps the compiler find the source code
of the package being built and its dependencies, and GOBIN, which determines
where executables (\"commands\") are installed to. This phase is sometimes used
diff --git a/guix/store/deduplication.scm b/guix/store/deduplication.scm
index 8ca16a4cd8..d42c40932c 100644
--- a/guix/store/deduplication.scm
+++ b/guix/store/deduplication.scm
@@ -79,8 +79,8 @@ unused by the time you create anything with that name, but a good shot."
(define* (get-temp-link target #:optional (link-prefix (dirname target)))
"Like mkstemp!, but instead of creating a new file and giving you the name,
it creates a new hardlink to TARGET and gives you the name. Since
-cross-filesystem hardlinks don't work, the temp link must be created on the
-same filesystem - where in that filesystem it is can be controlled by
+cross-file-system hardlinks don't work, the temp link must be created on the
+same file system - where in that file system it is can be controlled by
LINK-PREFIX."
(let try ((tempname (tempname-in link-prefix)))
(catch 'system-error