summaryrefslogtreecommitdiff
path: root/guix
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-11-22 18:09:39 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-11-22 19:44:43 +0200
commit3dbf3a7f516cb5576ce77d9545cfa56b741f279b (patch)
tree3b995a3361db07339286090b15d2824070aaab8a /guix
parent93b14be52e2ae7c0be7dce5005262ca2dab77985 (diff)
downloadguix-patches-3dbf3a7f516cb5576ce77d9545cfa56b741f279b.tar
guix-patches-3dbf3a7f516cb5576ce77d9545cfa56b741f279b.tar.gz
build-system/cargo: Set openssl environment variable when available.
* guix/build/cargo-build-system.scm (configure): When openssl is available set the OPENSSL_DIR variable to discover its location. * gnu/packages/crates-io.scm (rust-curl-sys-0.4, rust-libgit2-sys-0.10, rust-libpijul-0.12, rust-libssh2-sys-0.2, rust-native-tls-0.2, rust-openssl-sys-0.9, rust-openssl-0.7, rust-trust-dns-rustls-0.6), * gnu/packages/rust-apps.scm (tokei, exa)[arguments]: Remove redundant setenv for openssl.
Diffstat (limited to 'guix')
-rw-r--r--guix/build/cargo-build-system.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/guix/build/cargo-build-system.scm b/guix/build/cargo-build-system.scm
index 117c8da66c..22c5d3b530 100644
--- a/guix/build/cargo-build-system.scm
+++ b/guix/build/cargo-build-system.scm
@@ -122,6 +122,8 @@ directory = '" port)
(setenv "CC" (string-append (assoc-ref inputs "gcc") "/bin/gcc"))
(setenv "LIBGIT2_SYS_USE_PKG_CONFIG" "1")
(setenv "LIBSSH2_SYS_USE_PKG_CONFIG" "1")
+ (when (assoc-ref inputs "openssl")
+ (setenv "OPENSSL_DIR" (assoc-ref inputs "openssl")))
;; We don't use the Cargo.lock file to determine the package versions we use
;; during building, and in any case if one is not present it is created