summaryrefslogtreecommitdiff
path: root/guix/self.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2018-11-24 12:25:03 +0900
committerLudovic Courtès <ludo@gnu.org>2019-01-17 14:04:21 +0100
commita49d633c0c65975263270f5ac0050482ca6a5513 (patch)
tree362e0df559e06cacb31b04fd384344ef789ef0dc /guix/self.scm
parent113bdf6ae1819022d8c0d640b78a37c7d6b52723 (diff)
downloadguix-patches-a49d633c0c65975263270f5ac0050482ca6a5513.tar
guix-patches-a49d633c0c65975263270f5ac0050482ca6a5513.tar.gz
installer: Move everything to the build side.
* gnu/installer.scm: Rename to ... * gnu/installer/record.scm: ... this. * gnu/installer/build-installer.scm: Move everything to the build side and rename to gnu/installer.scm. * gnu/installer/newt.scm: Remove all the gexps and add depencies to newt modules as this code will only be used on the build side by now. * gnu/local.mk (GNU_SYSTEM_MODULES): Adapt it, (dist_installer_DATA): New rule to install installer's aux-files. * gnu/system/install.scm (%installation-services): Use only 'installer-program' from (gnu installer). The installer is now choosen on the build side. * guix/self.scm (*system-modules*): Restore previous behaviour and add all installer files to #:extra-files field of the scheme-node. * po/guix/POTFILES.in: Adapt it.
Diffstat (limited to 'guix/self.scm')
-rw-r--r--guix/self.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/guix/self.scm b/guix/self.scm
index 2698596387..4df4f6506e 100644
--- a/guix/self.scm
+++ b/guix/self.scm
@@ -604,11 +604,7 @@ Info manual."
(scheme-node "guix-system"
`((gnu system)
(gnu services)
- ,@(filter-map
- (match-lambda
- (('gnu 'system 'install) #f)
- (name name))
- (scheme-modules* source "gnu/system"))
+ ,@(scheme-modules* source "gnu/system")
,@(scheme-modules* source "gnu/services"))
(list *core-package-modules* *package-modules*
*extra-modules* *core-modules*)
@@ -616,7 +612,9 @@ Info manual."
#:extra-files
(append (file-imports source "gnu/system/examples"
(const #t))
-
+ ;; All the installer code is on the build-side.
+ (file-imports source "gnu/installer/"
+ (const #t))
;; Build-side code that we don't build. Some of
;; these depend on guile-rsvg, the Shepherd, etc.
(file-imports source "gnu/build" (const #t)))