summaryrefslogtreecommitdiff
path: root/guix/scripts/weather.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-12-24 15:50:54 +0000
committerChristopher Baines <mail@cbaines.net>2021-01-16 11:51:03 +0000
commit681af17460fa34916ac40589cccdcca7222249af (patch)
tree627bcd3b60a2835d0f6bed67db47dbdc664425ee /guix/scripts/weather.scm
parent35e0c0cf1d2a749d5c3255ef50cd5bfb014bca39 (diff)
downloadguix-patches-681af17460fa34916ac40589cccdcca7222249af.tar
guix-patches-681af17460fa34916ac40589cccdcca7222249af.tar.gz
guix: Move narinfo code from substitute script to module.
This separation between the code for dealing with narinfos from the code doing that for a purpose should make things clearer, and better support components other that the substitute script in using this code. This is just moving the code around, no code should have been significantly changed. * guix/scripts/substitute.scm (<narinfo>): Move record type to (guix narinfo). (fields->alist, narinfo-hash-algorithm+value, narinfo-hash->sha256, narinfo-signature->canonical-sexp, narinfo-maker, read-narinfo, narinfo-sha256, valid-narinfo?, write-narinfo, narinfo->string, string->narinfo, equivalent-narinfo?, supported-compression?, compresses-better?, narinfo-best-uri): Move procedures to (guix narinfo). (%compression-methods): Move variable to (guix narinfo). * guix/narinfo.scm: New file. * Makefile.am (MODULES): Add it. * po/guix/POTFILES.in: Add 'guix/narinfo.scm'.
Diffstat (limited to 'guix/scripts/weather.scm')
-rw-r--r--guix/scripts/weather.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/guix/scripts/weather.scm b/guix/scripts/weather.scm
index f28070ddc4..97e4a73802 100644
--- a/guix/scripts/weather.scm
+++ b/guix/scripts/weather.scm
@@ -33,6 +33,7 @@
#:use-module ((guix build syscalls) #:select (terminal-columns))
#:use-module ((guix build utils) #:select (every*))
#:use-module (guix scripts substitute)
+ #:use-module (guix narinfo)
#:use-module (guix http-client)
#:use-module (guix ci)
#:use-module (guix sets)