summaryrefslogtreecommitdiff
path: root/guix/scripts/system.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-06-01 16:12:07 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-04 12:04:24 +0200
commit3f83c0b7c7b4761062184a01f0977199957383ad (patch)
treeb61c9c5effd781826e8b23685a0c1cee9b5e99e7 /guix/scripts/system.scm
parentf9fb00ff082a54ee113320329a7bd089d4d0b314 (diff)
downloadguix-patches-3f83c0b7c7b4761062184a01f0977199957383ad.tar
guix-patches-3f83c0b7c7b4761062184a01f0977199957383ad.tar.gz
guix system: Add 'edit' sub-command.
* guix/scripts/system/edit.scm: New file. * Makefile.am (MODULES): Add it. * guix/scripts/system.scm (show-help): Mention "edit". (actions): Add it. (process-command): Handle it. * doc/guix.texi (Invoking guix system): Document it. * po/guix/POTFILES.in: Add guix/scripts/system/edit.scm.
Diffstat (limited to 'guix/scripts/system.scm')
-rw-r--r--guix/scripts/system.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/guix/scripts/system.scm b/guix/scripts/system.scm
index eaa245eb44..261a1d226d 100644
--- a/guix/scripts/system.scm
+++ b/guix/scripts/system.scm
@@ -945,6 +945,8 @@ Some ACTIONS support additional ARGS.\n"))
(display (G_ "\
search search for existing service types\n"))
(display (G_ "\
+ edit edit the definition of an existing service type\n"))
+ (display (G_ "\
reconfigure switch to a new operating system configuration\n"))
(display (G_ "\
roll-back switch to the previous operating system configuration\n"))
@@ -1172,7 +1174,8 @@ Some ACTIONS support additional ARGS.\n"))
"extension-graph" "shepherd-graph"
"list-generations" "describe"
"delete-generations" "roll-back"
- "switch-generation" "search" "docker-image"))
+ "switch-generation" "search" "edit"
+ "docker-image"))
(define (process-action action args opts)
"Process ACTION, a sub-command, with the arguments are listed in ARGS.
@@ -1340,6 +1343,8 @@ argument list and OPTS is the option alist."
(display-system-generation generation))))
((search)
(apply (resolve-subcommand "search") args))
+ ((edit)
+ (apply (resolve-subcommand "edit") args))
;; The following commands need to use the store, but they do not need an
;; operating system configuration file.
((delete-generations)