summaryrefslogtreecommitdiff
path: root/guix/scripts/import
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-06-16 10:50:06 +0200
committerFederico Beffa <beffa@fbengineering.ch>2015-07-08 10:53:05 +0200
commit7f74a931ddccdb3b42558f8f8ee29b309d9231b9 (patch)
tree1804fcf24967f92cd15e4ee3c2ac13e5091bb8dd /guix/scripts/import
parent575b4b092d73403381277625794042a7b7253cfe (diff)
downloadguix-patches-7f74a931ddccdb3b42558f8f8ee29b309d9231b9.tar
guix-patches-7f74a931ddccdb3b42558f8f8ee29b309d9231b9.tar.gz
import: Add 'elpa' importer.
* guix/import/elpa.scm: New file. * guix/scripts/import.scm: Add "elpa" to 'importers'. * guix/scripts/import/elpa.scm: New file. * Makefile.am (MODULES): Add 'guix/import/elpa.scm' and 'guix/scripts/import/elpa.scm'. (SCM_TESTS): Add 'tests/elpa.scm'. * doc/guix.texi (Invoking guix import): Document it. * tests/elpa.scm: New file. * po/guix/POTFILES.in: Add 'guix/scripts/import/elpa.scm'.
Diffstat (limited to 'guix/scripts/import')
-rw-r--r--guix/scripts/import/elpa.scm98
1 files changed, 98 insertions, 0 deletions
diff --git a/guix/scripts/import/elpa.scm b/guix/scripts/import/elpa.scm
new file mode 100644
index 0000000000..9034eb74e7
--- /dev/null
+++ b/guix/scripts/import/elpa.scm
@@ -0,0 +1,98 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix scripts import elpa)
+ #:use-module (guix ui)
+ #:use-module (guix utils)
+ #:use-module (guix import elpa)
+ #:use-module (guix scripts import)
+ #:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-11)
+ #:use-module (srfi srfi-37)
+ #:use-module (ice-9 match)
+ #:use-module (ice-9 format)
+ #:export (guix-import-elpa))
+
+
+;;;
+;;; Command-line options.
+;;;
+
+(define %default-options
+ '((repo . 'gnu)))
+
+(define (show-help)
+ (display (_ "Usage: guix import elpa PACKAGE-NAME
+Import the latest package named PACKAGE-NAME from an ELPA repository.\n"))
+ (display (_ "
+ -a, --archive=ARCHIVE specify the archive repository"))
+ (display (_ "
+ -h, --help display this help and exit"))
+ (display (_ "
+ -V, --version display version information and exit"))
+ (newline)
+ (show-bug-report-information))
+
+(define %options
+ ;; Specification of the command-line options.
+ (cons* (option '(#\h "help") #f #f
+ (lambda args
+ (show-help)
+ (exit 0)))
+ (option '(#\V "version") #f #f
+ (lambda args
+ (show-version-and-exit "guix import elpa")))
+ (option '(#\a "archive") #t #f
+ (lambda (opt name arg result)
+ (alist-cons 'repo (string->symbol arg)
+ (alist-delete 'repo result))))
+ %standard-import-options))
+
+
+;;;
+;;; Entry point.
+;;;
+
+(define (guix-import-elpa . args)
+ (define (parse-options)
+ ;; Return the alist of option values.
+ (args-fold* args %options
+ (lambda (opt name arg result)
+ (leave (_ "~A: unrecognized option~%") name))
+ (lambda (arg result)
+ (alist-cons 'argument arg result))
+ %default-options))
+
+ (let* ((opts (parse-options))
+ (args (filter-map (match-lambda
+ (('argument . value)
+ value)
+ (_ #f))
+ (reverse opts))))
+ (match args
+ ((package-name)
+ (let ((sexp (elpa->guix-package package-name (assoc-ref opts 'repo))))
+ (unless sexp
+ (leave (_ "failed to download package '~a'~%") package-name))
+ sexp))
+ (()
+ (leave (_ "too few arguments~%")))
+ ((many ...)
+ (leave (_ "too many arguments~%"))))))
+
+;;; elpa.scm ends here