summaryrefslogtreecommitdiff
path: root/guix/scripts/import/gnu.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-11-11 15:30:58 +0100
committerLudovic Courtès <ludo@gnu.org>2014-11-11 15:31:35 +0100
commit7047133f0777789107bd9f61f62c7d6ca10ed164 (patch)
tree3d7cfbdd51d0dc54cd83cb9aa58c0692b4274bc4 /guix/scripts/import/gnu.scm
parent501d76475185127388c7776f89fb6526db4f1336 (diff)
downloadguix-patches-7047133f0777789107bd9f61f62c7d6ca10ed164.tar
guix-patches-7047133f0777789107bd9f61f62c7d6ca10ed164.tar.gz
import: Add GNU importer.
Suggested by Karl Berry <karl@gnu.org> and Andreas Enge <andreas@enge.fr>. * guix/import/gnu.scm, guix/scripts/import/gnu.scm: New files. * Makefile.am (MODULES): Add them. * guix/scripts/import.scm (importers): Add "gnu". * guix/gnu-maintenance.scm (gnu-release-archive-types): New procedure. (download-tarball): Export.
Diffstat (limited to 'guix/scripts/import/gnu.scm')
-rw-r--r--guix/scripts/import/gnu.scm104
1 files changed, 104 insertions, 0 deletions
diff --git a/guix/scripts/import/gnu.scm b/guix/scripts/import/gnu.scm
new file mode 100644
index 0000000000..5fac6db516
--- /dev/null
+++ b/guix/scripts/import/gnu.scm
@@ -0,0 +1,104 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix scripts import gnu)
+ #:use-module (guix ui)
+ #:use-module (guix utils)
+ #:use-module (guix import gnu)
+ #:use-module (guix scripts import)
+ #:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-11)
+ #:use-module (srfi srfi-37)
+ #:use-module (ice-9 match)
+ #:export (guix-import-gnu))
+
+
+;;;
+;;; Command-line options.
+;;;
+
+(define %default-options
+ '((key-download . interactive)))
+
+(define (show-help)
+ (display (_ "Usage: guix import gnu [OPTION...] PACKAGE
+Return a package declaration template for PACKAGE, a GNU package.\n"))
+ ;; '--key-download' taken from (guix scripts refresh).
+ (display (_ "
+ --key-download=POLICY
+ handle missing OpenPGP keys according to POLICY:
+ 'always', 'never', and 'interactive', which is also
+ used when 'key-download' is not specified"))
+ (newline)
+ (display (_ "
+ -h, --help display this help and exit"))
+ (display (_ "
+ -V, --version display version information and exit"))
+ (newline)
+ (show-bug-report-information))
+
+(define %options
+ ;; Specification of the command-line options.
+ (cons* (option '(#\h "help") #f #f
+ (lambda args
+ (show-help)
+ (exit 0)))
+ (option '(#\V "version") #f #f
+ (lambda args
+ (show-version-and-exit "guix import gnu")))
+ (option '("key-download") #t #f ;from (guix scripts refresh)
+ (lambda (opt name arg result)
+ (match arg
+ ((or "interactive" "always" "never")
+ (alist-cons 'key-download (string->symbol arg)
+ result))
+ (_
+ (leave (_ "unsupported policy: ~a~%")
+ arg)))))
+ %standard-import-options))
+
+
+;;;
+;;; Entry point.
+;;;
+
+(define (guix-import-gnu . args)
+ (define (parse-options)
+ ;; Return the alist of option values.
+ (args-fold* args %options
+ (lambda (opt name arg result)
+ (leave (_ "~A: unrecognized option~%") name))
+ (lambda (arg result)
+ (alist-cons 'argument arg result))
+ %default-options))
+
+ (let* ((opts (parse-options))
+ (args (filter-map (match-lambda
+ (('argument . value)
+ value)
+ (_ #f))
+ (reverse opts))))
+ (match args
+ ((name)
+ (with-error-handling
+ (gnu->guix-package name
+ #:key-download (assoc-ref opts 'key-download))))
+ (_
+ (leave (_ "wrong number of arguments~%"))))))
+
+;;; gnu.scm ends here