summaryrefslogtreecommitdiff
path: root/guix/scripts/import.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-24 22:17:30 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-10-07 22:35:28 +0200
commitd780d0a2bbd1cdb7b688b3933ec6d6a1eb27e150 (patch)
tree36c6829899926d022ebdc35b610a0ebbad5cc54f /guix/scripts/import.scm
parentf63c79bf7674df012517f8e9148f94c611e35f32 (diff)
downloadguix-patches-d780d0a2bbd1cdb7b688b3933ec6d6a1eb27e150.tar
guix-patches-d780d0a2bbd1cdb7b688b3933ec6d6a1eb27e150.tar.gz
import: Add hex.pm importer.
hex.pm is a package repository for Erlang and Elixir. * guix/scripts/import.scm (importers): Add "hexpm". * guix/scripts/import/hexpm.scm, guix/import/hexpm.scm, guix/hexpm-download.scm: New files. * guix/import/utils.scm (source-spec->object): Add "hexpm-fetch" to list of fetch methods. * guix/upstream.scm (package-update/hexpm-fetch): New function. (%method-updates) Add it. * Makefile.am: Add them.
Diffstat (limited to 'guix/scripts/import.scm')
-rw-r--r--guix/scripts/import.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/guix/scripts/import.scm b/guix/scripts/import.scm
index 40fa6759ae..aaadad4adf 100644
--- a/guix/scripts/import.scm
+++ b/guix/scripts/import.scm
@@ -79,7 +79,7 @@ rather than \\n."
;;;
(define importers '("gnu" "pypi" "cpan" "hackage" "stackage" "egg" "elpa"
- "gem" "go" "cran" "crate" "texlive" "json" "opam"
+ "gem" "go" "cran" "crate" "texlive" "json" "opam" "hexpm"
"minetest"))
(define (resolve-importer name)