summaryrefslogtreecommitdiff
path: root/guix/scripts/home
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-10-30 12:42:41 +0200
committerLudovic Courtès <ludo@gnu.org>2021-10-31 00:51:05 +0200
commit40acbaf0789d47464062622bef463921556c2235 (patch)
tree0e68bcd922664d151d6f325efa792ada2d3da63f /guix/scripts/home
parent87c04b0e170a62aa60c8f2054ad039d169751b9c (diff)
downloadguix-patches-40acbaf0789d47464062622bef463921556c2235.tar
guix-patches-40acbaf0789d47464062622bef463921556c2235.tar.gz
Add tests for ‘guix home import’.
* tests/home-import.scm: New file. * Makefile.am (SCM_TESTS): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'guix/scripts/home')
-rw-r--r--guix/scripts/home/import.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/guix/scripts/home/import.scm b/guix/scripts/home/import.scm
index f0ae233b75..6e3ed065d5 100644
--- a/guix/scripts/home/import.scm
+++ b/guix/scripts/home/import.scm
@@ -27,7 +27,10 @@
#:use-module (ice-9 pretty-print)
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26)
- #:export (import-manifest))
+ #:export (import-manifest
+
+ ;; For tests.
+ manifest->code))
;;; Commentary:
;;;
@@ -36,6 +39,8 @@
;;;
;;; Code:
+
+
(define (generate-bash-configuration+modules destination-directory)
(define (destination-append path)
(string-append destination-directory "/" path))