summaryrefslogtreecommitdiff
path: root/guix/scripts/home.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-06-01 16:54:40 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-04 12:04:24 +0200
commit35c1edb20ad07250728d3bdcd0296bd0cedaf6bb (patch)
tree54e090e2a46f7f867f85df5d3a24ba8e862f54cd /guix/scripts/home.scm
parent8eb17cebc1027b5ae1c4047c704b92ad73b783fd (diff)
downloadguix-patches-35c1edb20ad07250728d3bdcd0296bd0cedaf6bb.tar
guix-patches-35c1edb20ad07250728d3bdcd0296bd0cedaf6bb.tar.gz
guix home: Add 'edit' sub-command.
* guix/scripts/home/edit.scm: New file. * Makefile.am (MODULES): Add it. * guix/scripts/home.scm (show-help): Add "edit". (process-command): Handle it. (guix-home): Add it. * po/guix/POTFILES.in: Add 'guix/scripts/home/edit.scm'. * doc/guix.texi (Invoking guix home): Document it.
Diffstat (limited to 'guix/scripts/home.scm')
-rw-r--r--guix/scripts/home.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/guix/scripts/home.scm b/guix/scripts/home.scm
index f43bf865a7..0f5c3388a1 100644
--- a/guix/scripts/home.scm
+++ b/guix/scripts/home.scm
@@ -60,6 +60,7 @@
#:autoload (guix scripts pull) (channel-commit-hyperlink)
#:autoload (guix scripts system) (service-node-type
shepherd-service-node-type)
+ #:autoload (guix scripts home edit) (guix-home-edit)
#:autoload (guix scripts home import) (import-manifest)
#:use-module ((guix status) #:select (with-status-verbosity))
#:use-module ((guix build utils) #:select (mkdir-p))
@@ -93,6 +94,8 @@ Some ACTIONS support additional ARGS.\n"))
(newline)
(display (G_ "\
search search for existing service types\n"))
+ (display (G_ "\
+ edit edit the definition of an existing service type\n"))
(display (G_ "
container run the home environment configuration in a container\n"))
(display (G_ "\
@@ -539,6 +542,8 @@ argument list and OPTS is the option alist."
;; an home environment file.
((search)
(apply search args))
+ ((edit)
+ (apply guix-home-edit args))
((import)
(let* ((profiles (delete-duplicates
(match (filter-map (match-lambda
@@ -611,7 +616,7 @@ deploy the home environment described by these files.\n")
extension-graph shepherd-graph
list-generations describe
delete-generations roll-back
- switch-generation search
+ switch-generation search edit
import container)
(alist-cons 'action action result))
(else (leave (G_ "~a: unknown action~%") action))))))