summaryrefslogtreecommitdiff
path: root/guix/packages.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-03-29 22:49:00 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-30 11:08:39 +0100
commitadb6462c4ce51fcdc94d3608ad6efb4adf716018 (patch)
treec5306452e40c282bb5c27909dbc6b5a515d54ffc /guix/packages.scm
parentd2be7e3c4ba8d6d0dde9b4c0bff623ab85637424 (diff)
downloadguix-patches-adb6462c4ce51fcdc94d3608ad6efb4adf716018.tar
guix-patches-adb6462c4ce51fcdc94d3608ad6efb4adf716018.tar.gz
packages: Define 'this-package' and 'this-origin'.
* guix/packages.scm (<origin>): Choose 'this-origin' as the 'this' identifier. (<package>): Choose 'this-package'. * gnu/packages/gnucash.scm (gnucash)[arguments]: Use 'this-package' instead of 'this-record'. * gnu/packages/version-control.scm (git)[arguments]: Likewise.
Diffstat (limited to 'guix/packages.scm')
-rw-r--r--guix/packages.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/guix/packages.scm b/guix/packages.scm
index 9d83de3d48..b402637508 100644
--- a/guix/packages.scm
+++ b/guix/packages.scm
@@ -48,6 +48,7 @@
search-path-specification) ;for convenience
#:export (origin
origin?
+ this-origin
origin-uri
origin-method
origin-sha256
@@ -63,6 +64,7 @@
package
package?
+ this-package
package-name
package-upstream-name
package-version
@@ -156,6 +158,7 @@
(define-record-type* <origin>
origin make-origin
origin?
+ this-origin
(uri origin-uri) ; string
(method origin-method) ; procedure
(sha256 origin-sha256) ; bytevector
@@ -247,6 +250,7 @@ name of its URI."
(define-record-type* <package>
package make-package
package?
+ this-package
(name package-name) ; string
(version package-version) ; string
(source package-source) ; <origin> instance