summaryrefslogtreecommitdiff
path: root/guix/packages.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-03-10 08:48:19 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-03-10 19:41:15 +0100
commit33bb89c939aee88bd211964db600df65d1b656af (patch)
tree408f20f47952b581feee09760a68734f59500108 /guix/packages.scm
parentcab3b57543bf42247870e56ffb1acd685d854d97 (diff)
downloadguix-patches-33bb89c939aee88bd211964db600df65d1b656af.tar
guix-patches-33bb89c939aee88bd211964db600df65d1b656af.tar.gz
ci: Remove hydra support.
This removes hydra support to use Cuirass as the only continuous integration system. * build-aux/hydra/gnu-system.scm: Remove it. * build-aux/hydra/guix-modular.scm: Ditto. * build-aux/hydra/guix.scm: Ditto. * build-aux/cuirass/hydra-to-cuirass.scm: Ditto. * Makefile.am (EXTRA_DIST): Update it. (hydra-jobs.scm): Remove it. (cuirass-jobs.scm): Update it. * build-aux/hydra/evaluate.scm: Move it to ... * build-aux/cuirass/evaluate.scm: ... here. * build-aux/cuirass/guix-modular.scm: Remove it. * build-aux/cuirass/gnu-system.scm: Ditto. * guix/packages.scm (%hydra-supported-systems): Rename it to ... (%cuirass-supported-systems): ... this variable. * build-aux/check-final-inputs-self-contained: Adapt it. * etc/release-manifest.scm: Ditto. * gnu/ci.scm (package->alist): Remove it. (derivation->job): New procedure. (package-job, package-cross-job, cross-jobs, image-jobs, system-test-jobs, tarball-jobs): Use it. (guix-jobs): New procedure. (hydra-jobs): Rename it to ... (cuirass-jobs): ... this procedure.
Diffstat (limited to 'guix/packages.scm')
-rw-r--r--guix/packages.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/guix/packages.scm b/guix/packages.scm
index 2dbcc7ba8b..dd1d473fca 100644
--- a/guix/packages.scm
+++ b/guix/packages.scm
@@ -134,7 +134,7 @@
%supported-systems
%hurd-systems
- %hydra-supported-systems
+ %cuirass-supported-systems
supported-package?
&package-error
@@ -354,7 +354,7 @@ name of its URI."
;; The GNU/Hurd systems for which support is being developed.
'("i586-gnu" "i686-gnu"))
-(define %hydra-supported-systems
+(define %cuirass-supported-systems
;; This is the list of system types for which build machines are available.
;;
;; XXX: MIPS is unavailable in CI: