summaryrefslogtreecommitdiff
path: root/guix/hash.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-07-01 23:28:21 +0200
committerLudovic Courtès <ludo@gnu.org>2013-07-01 23:28:21 +0200
commit72626a71a96b02fccb2281713c1fdcd09aa194c4 (patch)
treef24a4f73ee47d6478b5ef3a48ddb16e6403b7275 /guix/hash.scm
parent82323a80850a205866c83a9399cc76336e30847d (diff)
downloadguix-patches-72626a71a96b02fccb2281713c1fdcd09aa194c4.tar
guix-patches-72626a71a96b02fccb2281713c1fdcd09aa194c4.tar.gz
Move `sha256' to (guix hash).
* guix/utils.scm (sha256): Move to... * guix/hash.scm: ... here. New file. * Makefile.am (MODULES): Add it. * guix/derivations.scm, guix/scripts/download.scm, guix/scripts/hash.scm, guix/scripts/refresh.scm, tests/base32.scm, tests/derivations.scm, tests/store.scm: Use (guix hash).
Diffstat (limited to 'guix/hash.scm')
-rw-r--r--guix/hash.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/guix/hash.scm b/guix/hash.scm
new file mode 100644
index 0000000000..1c7e342803
--- /dev/null
+++ b/guix/hash.scm
@@ -0,0 +1,49 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix hash)
+ #:use-module (guix config)
+ #:use-module (rnrs bytevectors)
+ #:use-module (system foreign)
+ #:export (sha256))
+
+;;; Commentary:
+;;;
+;;; Cryptographic hashes.
+;;;
+;;; Code:
+
+
+;;;
+;;; Hash.
+;;;
+
+(define sha256
+ (let ((hash (pointer->procedure void
+ (dynamic-func "gcry_md_hash_buffer"
+ (dynamic-link %libgcrypt))
+ `(,int * * ,size_t)))
+ (sha256 8)) ; GCRY_MD_SHA256, as of 1.5.0
+ (lambda (bv)
+ "Return the SHA256 of BV as a bytevector."
+ (let ((digest (make-bytevector (/ 256 8))))
+ (hash sha256 (bytevector->pointer digest)
+ (bytevector->pointer bv) (bytevector-length bv))
+ digest))))
+
+;;; hash.scm ends here