summaryrefslogtreecommitdiff
path: root/guix/build
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-04-17 00:08:34 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-04-17 00:08:34 +0200
commitf5961dd5854cec1ed9a41365836d63aa15256642 (patch)
tree9e6168827adf5e4e90128d55fad6f0ab6448c86a /guix/build
parent05bb85fda06dc361b8d3d1eef0759606784b3130 (diff)
parente28ff04108ae7506a21d451cc23d63937076e2a3 (diff)
downloadguix-patches-f5961dd5854cec1ed9a41365836d63aa15256642.tar
guix-patches-f5961dd5854cec1ed9a41365836d63aa15256642.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'guix/build')
-rw-r--r--guix/build/cargo-build-system.scm155
-rw-r--r--guix/build/linux-module-build-system.scm91
2 files changed, 178 insertions, 68 deletions
diff --git a/guix/build/cargo-build-system.scm b/guix/build/cargo-build-system.scm
index 20087fa6c4..b68a1f90d2 100644
--- a/guix/build/cargo-build-system.scm
+++ b/guix/build/cargo-build-system.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2019 Ivan Petkov <ivanppetkov@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,6 +27,7 @@
#:use-module (ice-9 ftw)
#:use-module (ice-9 format)
#:use-module (ice-9 match)
+ #:use-module (json parser)
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26)
#:export (%standard-phases
@@ -37,81 +39,86 @@
;;
;; Code:
-;; FIXME: Needs to be parsed from url not package name.
-(define (package-name->crate-name name)
- "Return the crate name of NAME."
- (match (string-split name #\-)
- (("rust" rest ...)
- (string-join rest "-"))
- (_ #f)))
-
-(define* (configure #:key inputs #:allow-other-keys)
- "Replace Cargo.toml [dependencies] section with guix inputs."
- ;; Make sure Cargo.toml is writeable when the crate uses git-fetch.
- (chmod "Cargo.toml" #o644)
+(define (manifest-targets)
+ "Extract all targets from the Cargo.toml manifest"
+ (let* ((port (open-input-pipe "cargo read-manifest"))
+ (data (json->scm port))
+ (targets (hash-ref data "targets" '())))
+ (close-port port)
+ targets))
+
+(define (has-executable-target?)
+ "Check if the current cargo project declares any binary targets."
+ (let* ((bin? (lambda (kind) (string=? kind "bin")))
+ (get-kinds (lambda (dep) (hash-ref dep "kind")))
+ (bin-dep? (lambda (dep) (find bin? (get-kinds dep)))))
+ (find bin-dep? (manifest-targets))))
+
+(define* (configure #:key inputs
+ (vendor-dir "guix-vendor")
+ #:allow-other-keys)
+ "Vendor Cargo.toml dependencies as guix inputs."
(chmod "." #o755)
- (if (not (file-exists? "vendor"))
- (if (not (file-exists? "Cargo.lock"))
- (begin
- (substitute* "Cargo.toml"
- ((".*32-sys.*") "
-")
- ((".*winapi.*") "
-")
- ((".*core-foundation.*") "
-"))
- ;; Prepare one new directory with all the required dependencies.
- ;; It's necessary to do this (instead of just using /gnu/store as the
- ;; directory) because we want to hide the libraries in subdirectories
- ;; share/rust-source/... instead of polluting the user's profile root.
- (mkdir "vendor")
- (for-each
- (match-lambda
- ((name . path)
- (let ((crate (package-name->crate-name name)))
- (when (and crate path)
- (match (string-split (basename path) #\-)
- ((_ ... version)
- (symlink (string-append path "/share/rust-source")
- (string-append "vendor/" (basename path)))))))))
- inputs)
- ;; Configure cargo to actually use this new directory.
- (mkdir-p ".cargo")
- (let ((port (open-file ".cargo/config" "w" #:encoding "utf-8")))
- (display "
+ ;; Prepare one new directory with all the required dependencies.
+ ;; It's necessary to do this (instead of just using /gnu/store as the
+ ;; directory) because we want to hide the libraries in subdirectories
+ ;; share/rust-source/... instead of polluting the user's profile root.
+ (mkdir-p vendor-dir)
+ (for-each
+ (match-lambda
+ ((name . path)
+ (let* ((rust-share (string-append path "/share/rust-source"))
+ (basepath (basename path))
+ (link-dir (string-append vendor-dir "/" basepath)))
+ (and (file-exists? rust-share)
+ ;; Gracefully handle duplicate inputs
+ (not (file-exists? link-dir))
+ (symlink rust-share link-dir)))))
+ inputs)
+ ;; Configure cargo to actually use this new directory.
+ (mkdir-p ".cargo")
+ (let ((port (open-file ".cargo/config" "w" #:encoding "utf-8")))
+ (display "
[source.crates-io]
-registry = 'https://github.com/rust-lang/crates.io-index'
replace-with = 'vendored-sources'
[source.vendored-sources]
directory = '" port)
- (display (getcwd) port)
- (display "/vendor" port)
- (display "'
+ (display (string-append (getcwd) "/" vendor-dir) port)
+ (display "'
" port)
- (close-port port)))))
- (setenv "CC" (string-append (assoc-ref inputs "gcc") "/bin/gcc"))
+ (close-port port))
- ;(setenv "CARGO_HOME" "/gnu/store")
- ; (setenv "CMAKE_C_COMPILER" cc)
+ ;; Lift restriction on any lints: a crate author may have decided to opt
+ ;; into stricter lints (e.g. #![deny(warnings)]) during their own builds
+ ;; but we don't want any build failures that could be caused later by
+ ;; upgrading the compiler for example.
+ (setenv "RUSTFLAGS" "--cap-lints allow")
+ (setenv "CC" (string-append (assoc-ref inputs "gcc") "/bin/gcc"))
#t)
-(define* (build #:key (cargo-build-flags '("--release"))
+(define* (build #:key
+ skip-build?
+ (cargo-build-flags '("--release"))
#:allow-other-keys)
"Build a given Cargo package."
- (zero? (apply system* `("cargo" "build" ,@cargo-build-flags))))
+ (or skip-build?
+ (zero? (apply system* `("cargo" "build" ,@cargo-build-flags)))))
-(define* (check #:key tests? #:allow-other-keys)
+(define* (check #:key
+ tests?
+ (cargo-test-flags '("--release"))
+ #:allow-other-keys)
"Run tests for a given Cargo package."
- (if (and tests? (file-exists? "Cargo.lock"))
- (zero? (system* "cargo" "test"))
+ (if tests?
+ (zero? (apply system* `("cargo" "test" ,@cargo-test-flags)))
#t))
(define (touch file-name)
(call-with-output-file file-name (const #t)))
-(define* (install #:key inputs outputs #:allow-other-keys)
- "Install a given Cargo package."
+(define* (install-source #:key inputs outputs #:allow-other-keys)
+ "Install the source for a given Cargo package."
(let* ((out (assoc-ref outputs "out"))
(src (assoc-ref inputs "source"))
(rsrc (string-append (assoc-ref outputs "src")
@@ -120,24 +127,36 @@ directory = '" port)
;; Rust doesn't have a stable ABI yet. Because of this
;; Cargo doesn't have a search path for binaries yet.
;; Until this changes we are working around this by
- ;; distributing crates as source and replacing
- ;; references in Cargo.toml with store paths.
- (copy-recursively "src" (string-append rsrc "/src"))
+ ;; vendoring the crates' sources by symlinking them
+ ;; to store paths.
+ (copy-recursively "." rsrc)
(touch (string-append rsrc "/.cargo-ok"))
- (generate-checksums rsrc src)
+ (generate-checksums rsrc "/dev/null")
(install-file "Cargo.toml" rsrc)
- ;; When the package includes executables we install
- ;; it using cargo install. This fails when the crate
- ;; doesn't contain an executable.
- (if (file-exists? "Cargo.lock")
- (zero? (system* "cargo" "install" "--root" out))
- (begin
- (mkdir out)
- #t))))
+ #t))
+
+(define* (install #:key inputs outputs skip-build? #:allow-other-keys)
+ "Install a given Cargo package."
+ (let* ((out (assoc-ref outputs "out")))
+ (mkdir-p out)
+
+ ;; Make cargo reuse all the artifacts we just built instead
+ ;; of defaulting to making a new temp directory
+ (setenv "CARGO_TARGET_DIR" "./target")
+ ;; Force cargo to honor our .cargo/config definitions
+ ;; https://github.com/rust-lang/cargo/issues/6397
+ (setenv "CARGO_HOME" ".")
+
+ ;; Only install crates which include binary targets,
+ ;; otherwise cargo will raise an error.
+ (or skip-build?
+ (not (has-executable-target?))
+ (zero? (system* "cargo" "install" "--path" "." "--root" out)))))
(define %standard-phases
(modify-phases gnu:%standard-phases
(delete 'bootstrap)
+ (add-before 'configure 'install-source install-source)
(replace 'configure configure)
(replace 'build build)
(replace 'check check)
diff --git a/guix/build/linux-module-build-system.scm b/guix/build/linux-module-build-system.scm
new file mode 100644
index 0000000000..cd76df2de7
--- /dev/null
+++ b/guix/build/linux-module-build-system.scm
@@ -0,0 +1,91 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Danny Milosavljevic <dannym@scratchpost.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix build linux-module-build-system)
+ #:use-module ((guix build gnu-build-system) #:prefix gnu:)
+ #:use-module (guix build utils)
+ #:use-module (ice-9 ftw)
+ #:use-module (ice-9 match)
+ #:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-26)
+ #:export (%standard-phases
+ linux-module-build))
+
+;; Commentary:
+;;
+;; Builder-side code of linux-module build.
+;;
+;; Code:
+
+;; Copied from make-linux-libre's "configure" phase.
+(define* (configure #:key inputs target #:allow-other-keys)
+ (setenv "KCONFIG_NOTIMESTAMP" "1")
+ (setenv "KBUILD_BUILD_TIMESTAMP" (getenv "SOURCE_DATE_EPOCH"))
+ ;(let ((arch ,(system->linux-architecture
+ ; (or (%current-target-system)
+ ; (%current-system)))))
+ ; (setenv "ARCH" arch)
+ ; (format #t "`ARCH' set to `~a'~%" (getenv "ARCH")))
+ (when target
+ (setenv "CROSS_COMPILE" (string-append target "-"))
+ (format #t "`CROSS_COMPILE' set to `~a'~%"
+ (getenv "CROSS_COMPILE")))
+ ; TODO: (setenv "EXTRA_VERSION" ,extra-version)
+ ; TODO: kernel ".config".
+ #t)
+
+(define* (build #:key inputs make-flags #:allow-other-keys)
+ (apply invoke "make" "-C"
+ (string-append (assoc-ref inputs "linux-module-builder")
+ "/lib/modules/build")
+ (string-append "M=" (getcwd))
+ (or make-flags '())))
+
+;; This block was copied from make-linux-libre--only took the "modules_install"
+;; part.
+(define* (install #:key inputs native-inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (moddir (string-append out "/lib/modules"))
+ (kmod (assoc-ref (or native-inputs inputs) "kmod")))
+ ;; Install kernel modules
+ (mkdir-p moddir)
+ (invoke "make" "-C"
+ (string-append (assoc-ref inputs "linux-module-builder")
+ "/lib/modules/build")
+ (string-append "M=" (getcwd))
+ (string-append "DEPMOD=" kmod "/bin/depmod")
+ (string-append "MODULE_DIR=" moddir)
+ (string-append "INSTALL_PATH=" out)
+ (string-append "INSTALL_MOD_PATH=" out)
+ "INSTALL_MOD_STRIP=1"
+ "modules_install")))
+
+(define %standard-phases
+ (modify-phases gnu:%standard-phases
+ (replace 'configure configure)
+ (replace 'build build)
+ (replace 'install install)))
+
+(define* (linux-module-build #:key inputs (phases %standard-phases)
+ #:allow-other-keys #:rest args)
+ "Build the given package, applying all of PHASES in order, with a Linux kernel in attendance."
+ (apply gnu:gnu-build
+ #:inputs inputs #:phases phases
+ args))
+
+;;; linux-module-build-system.scm ends here