summaryrefslogtreecommitdiff
path: root/guix/build
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-10-20 10:15:29 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-10-20 12:23:52 +0300
commit408a4ed071c9c52de207d799a698781d49fa727d (patch)
tree3b617f5cfebe56642c57b1607fec80ac3ca056ef /guix/build
parent3d6f6d3b45b4fc6a448045f64ca098612e3e943a (diff)
downloadguix-patches-408a4ed071c9c52de207d799a698781d49fa727d.tar
guix-patches-408a4ed071c9c52de207d799a698781d49fa727d.tar.gz
build-system/cargo: Unpack crates less verbosely.
* guix/build/cargo-build-system.scm (configure): Print the crate being unpacked but don't print the contents of each crate.
Diffstat (limited to 'guix/build')
-rw-r--r--guix/build/cargo-build-system.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/guix/build/cargo-build-system.scm b/guix/build/cargo-build-system.scm
index 0a95672b00..41766228c2 100644
--- a/guix/build/cargo-build-system.scm
+++ b/guix/build/cargo-build-system.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2019 Ivan Petkov <ivanppetkov@gmail.com>
-;;; Copyright © 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019-2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;;
@@ -135,7 +135,8 @@ Cargo.toml file present at its root."
;; so that we can generate any cargo checksums.
;; The --strip-components argument is needed to prevent creating
;; an extra directory within `crate-dir`.
- (invoke "tar" "xvf" path "-C" crate-dir "--strip-components" "1")))))
+ (format #t "Unpacking ~a~%" name)
+ (invoke "tar" "xf" path "-C" crate-dir "--strip-components" "1")))))
inputs)
;; Configure cargo to actually use this new directory.