summaryrefslogtreecommitdiff
path: root/guix/build
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-29 11:12:49 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-29 11:12:49 +0100
commit0895002f68a51de2c237e1fe83ec6e4ffc980eff (patch)
tree34b1dbfafef2e98892c793c2001f028d1e88efd0 /guix/build
parent333d15790caec5c6782c3889a29b6f91d40ac42d (diff)
parent602059e794182a035f3919c3eb88d7d2085e24df (diff)
downloadguix-patches-0895002f68a51de2c237e1fe83ec6e4ffc980eff.tar
guix-patches-0895002f68a51de2c237e1fe83ec6e4ffc980eff.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'guix/build')
-rw-r--r--guix/build/cargo-build-system.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/guix/build/cargo-build-system.scm b/guix/build/cargo-build-system.scm
index 8a8d74ee1b..0721989589 100644
--- a/guix/build/cargo-build-system.scm
+++ b/guix/build/cargo-build-system.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2019 Ivan Petkov <ivanppetkov@gmail.com>
-;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -58,7 +58,7 @@
(define (crate-src? path)
"Check if PATH refers to a crate source, namely a gzipped tarball with a
Cargo.toml file present at its root."
- (and (gzip-file? path)
+ (and (not (directory-exists? path)) ; not a tarball
;; First we print out all file names within the tarball to see if it
;; looks like the source of a crate. However, the tarball will include
;; an extra path component which we would like to ignore (since we're
@@ -119,6 +119,8 @@ directory = '" port)
;; upgrading the compiler for example.
(setenv "RUSTFLAGS" "--cap-lints allow")
(setenv "CC" (string-append (assoc-ref inputs "gcc") "/bin/gcc"))
+ (setenv "LIBGIT2_SYS_USE_PKG_CONFIG" "1")
+ (setenv "LIBSSH2_SYS_USE_PKG_CONFIG" "1")
;; We don't use the Cargo.lock file to determine the package versions we use
;; during building, and in any case if one is not present it is created