summaryrefslogtreecommitdiff
path: root/guix/build/svn.scm
diff options
context:
space:
mode:
authorSree Harsha Totakura <sreeharsha@totakura.in>2014-03-26 17:59:01 +0100
committerLudovic Courtès <ludo@gnu.org>2014-03-27 00:21:44 +0100
commitb3acf3656eafb7b8b75c3eeb7e683ac46c9933bf (patch)
tree142f8622a48c504f285829b3ffc30ae9d80d56d9 /guix/build/svn.scm
parent8bae41a4cefce48af73afb46068ca84750a08da0 (diff)
downloadguix-patches-b3acf3656eafb7b8b75c3eeb7e683ac46c9933bf.tar
guix-patches-b3acf3656eafb7b8b75c3eeb7e683ac46c9933bf.tar.gz
Add (guix svn-download).
* guix/svn-download.scm, guix/build/svn.scm: New files. * Makefile.am (MODULES): Add them. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'guix/build/svn.scm')
-rw-r--r--guix/build/svn.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/guix/build/svn.scm b/guix/build/svn.scm
new file mode 100644
index 0000000000..74fe084da5
--- /dev/null
+++ b/guix/build/svn.scm
@@ -0,0 +1,49 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix build svn)
+ #:use-module (guix build utils)
+ #:export (svn-fetch))
+
+;;; Commentary:
+;;;
+;;; This is the build-side support code of (guix svn-download). It allows a
+;;; Subversion repository to be cloned and checked out at a specific revision.
+;;;
+;;; Code:
+
+(define* (svn-fetch url revision directory
+ #:key (svn-command "svn"))
+ "Fetch REVISION from URL into DIRECTORY. REVISION must be an integer, and a
+valid Subversion revision. Return #t on success, #f otherwise."
+ (and (zero? (system* svn-command "checkout" "--non-interactive"
+ ;; Trust the server certificate. This is OK as we
+ ;; verify the checksum later. This can be removed when
+ ;; ca-certificates package is added.
+ "--trust-server-cert" "-r" (number->string revision)
+ url directory))
+ (with-directory-excursion directory
+ (begin
+ ;; The contents of '.svn' vary as a function of the current status
+ ;; of the repo. Since we want a fixed output, this directory needs
+ ;; to be taken out.
+ (delete-file-recursively ".svn")
+ #t))))
+
+;;; svn.scm ends here