summaryrefslogtreecommitdiff
path: root/guix/build/qt-utils.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-08-25 23:06:27 +0200
committerDavid Craven <david@craven.ch>2016-08-30 22:38:28 +0200
commit2098d0240e89ec4fae49b33ee0990a7f833576b5 (patch)
tree8fddb5262c0c10183d565a3de2ed22fa7413b33c /guix/build/qt-utils.scm
parent225941b02813364dcba7203d2893adc5e99e1cbc (diff)
downloadguix-patches-2098d0240e89ec4fae49b33ee0990a7f833576b5.tar
guix-patches-2098d0240e89ec4fae49b33ee0990a7f833576b5.tar.gz
build: Add wrap-qt-program.
* guix/build/qt-utils.scm (wrap-qt-program): New file. * Makefile.am (MODULES): Add it.
Diffstat (limited to 'guix/build/qt-utils.scm')
-rw-r--r--guix/build/qt-utils.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/guix/build/qt-utils.scm b/guix/build/qt-utils.scm
new file mode 100644
index 0000000000..48a32674e9
--- /dev/null
+++ b/guix/build/qt-utils.scm
@@ -0,0 +1,40 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 David Craven <david@craven.ch>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix build qt-utils)
+ #:use-module (guix build utils)
+ #:export (wrap-qt-program))
+
+(define (wrap-qt-program out program)
+ (define (suffix env-var path)
+ (let ((env-val (getenv env-var)))
+ (if env-val (string-append env-val ":" path) path)))
+
+ (let ((qml-path (suffix "QML2_IMPORT_PATH"
+ (string-append out "/qml")))
+ (plugin-path (suffix "QT_PLUGIN_PATH"
+ (string-append out "/plugins")))
+ (xdg-data-path (suffix "XDG_DATA_DIRS"
+ (string-append out "/share")))
+ (xdg-config-path (suffix "XDG_CONFIG_DIRS"
+ (string-append out "/etc/xdg"))))
+ (wrap-program (string-append out "/bin/" program)
+ `("QML2_IMPORT_PATH" = (,qml-path))
+ `("QT_PLUGIN_PATH" = (,plugin-path))
+ `("XDG_DATA_DIRS" = (,xdg-data-path))
+ `("XDG_CONFIG_DIRS" = (,xdg-config-path)))))