summaryrefslogtreecommitdiff
path: root/guix/build/python-build-system.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-23 17:14:15 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-28 15:52:26 +0200
commita1454169e0080d834cbddf94f04c5bcb7c3703e9 (patch)
treeb0fee3132edaf19a3e785a788dfc99b6080cb8d2 /guix/build/python-build-system.scm
parentd66146073def03d1a3d61607bc6b77997284904b (diff)
downloadguix-patches-a1454169e0080d834cbddf94f04c5bcb7c3703e9.tar
guix-patches-a1454169e0080d834cbddf94f04c5bcb7c3703e9.tar.gz
gnu: python: Update to 3.7.0.
* gnu/packages/python.scm (python-3.6): Rename to ... (python-3.7): ... this. Update to 3.7.0. [arguments]: Remove phase 'patch-timestamp-for-pyc-files' and related code. Add phases to unset SOURCE_DATE_EPOCH during the check phase. (python-3): Is now PYTHON-3.7. * guix/build/python-build-system.scm (enable-bytecode-determinism): Don't set DETERMINISTIC_BUILD.
Diffstat (limited to 'guix/build/python-build-system.scm')
-rw-r--r--guix/build/python-build-system.scm2
1 files changed, 0 insertions, 2 deletions
diff --git a/guix/build/python-build-system.scm b/guix/build/python-build-system.scm
index 376ea81f1a..5bb0ba49d5 100644
--- a/guix/build/python-build-system.scm
+++ b/guix/build/python-build-system.scm
@@ -246,8 +246,6 @@ installed with setuptools."
(define* (enable-bytecode-determinism #:rest _)
"Improve determinism of pyc files."
- ;; Set DETERMINISTIC_BUILD to override the embedded mtime in pyc files.
- (setenv "DETERMINISTIC_BUILD" "1")
;; Use deterministic hashes for strings, bytes, and datetime objects.
(setenv "PYTHONHASHSEED" "0")
#t)