summaryrefslogtreecommitdiff
path: root/guix/build/meson-build-system.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-29 19:13:49 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-30 17:06:42 +0200
commit25280065814aecd7ce56baf4866b0c05acf8028b (patch)
tree6c7bc32aff322623031b99a3ca54e8cbbc90de8b /guix/build/meson-build-system.scm
parent1b0668272cb44d78a94b65ae0e004903b78e4138 (diff)
downloadguix-patches-25280065814aecd7ce56baf4866b0c05acf8028b.tar
guix-patches-25280065814aecd7ce56baf4866b0c05acf8028b.tar.gz
build-system/meson: Do not inherit the 'bootstrap' phase.
* guix/build/meson-build-system.scm (%standard-phases): Remove 'bootstrap'. * gnu/packages/glib.scm (glib)[arguments]: Adjust accordingly.
Diffstat (limited to 'guix/build/meson-build-system.scm')
-rw-r--r--guix/build/meson-build-system.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/guix/build/meson-build-system.scm b/guix/build/meson-build-system.scm
index d0975fcab0..8043a84abb 100644
--- a/guix/build/meson-build-system.scm
+++ b/guix/build/meson-build-system.scm
@@ -108,6 +108,7 @@ for example libraries only needed for the tests."
;; from the gnu-build-system. If the glib-or-gtk? key is #f (the default)
;; then the extra phases will be removed again in (guix build-system meson).
(modify-phases glib-or-gtk:%standard-phases
+ (delete 'bootstrap)
(replace 'configure configure)
(replace 'build build)
(replace 'check check)