summaryrefslogtreecommitdiff
path: root/guix/build/hg.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-06-15 10:38:10 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-06-15 17:02:18 +0200
commitc4e48b68bdf41e7f6805473fc4f545b215251c6d (patch)
tree9770d6e6dc0e6f1c9a7ef172a74dc6cb7ddc529c /guix/build/hg.scm
parent9c4a8514d621b6e2a19f56fa9b3396c940b968c5 (diff)
downloadguix-patches-c4e48b68bdf41e7f6805473fc4f545b215251c6d.tar
guix-patches-c4e48b68bdf41e7f6805473fc4f545b215251c6d.tar.gz
guix: Add downloader for Mercurial repositories.
* guix/build/hg.scm: New file. * guix/hg-download.scm: New file. * Makefile.am (MODULES): Add them.
Diffstat (limited to 'guix/build/hg.scm')
-rw-r--r--guix/build/hg.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/guix/build/hg.scm b/guix/build/hg.scm
new file mode 100644
index 0000000000..ae4574de57
--- /dev/null
+++ b/guix/build/hg.scm
@@ -0,0 +1,51 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix build hg)
+ #:use-module (guix build utils)
+ #:export (hg-fetch))
+
+;;; Commentary:
+;;;
+;;; This is the build-side support code of (guix hg-download). It allows a
+;;; Mercurial repository to be cloned and checked out at a specific changeset
+;;; identifier.
+;;;
+;;; Code:
+
+(define* (hg-fetch url changeset directory
+ #:key (hg-command "hg"))
+ "Fetch CHANGESET from URL into DIRECTORY. CHANGESET must be a valid
+Mercurial changeset identifier. Return #t on success, #f otherwise."
+
+ (and (zero? (system* hg-command
+ "clone" url
+ "--rev" changeset
+ ;; Disable TLS certificate verification. The hash of
+ ;; the checkout is known in advance anyway.
+ "--insecure"
+ directory))
+ (with-directory-excursion directory
+ (begin
+ ;; The contents of '.hg' vary as a function of the current
+ ;; status of the Mercurial repo. Since we want a fixed
+ ;; output, this directory needs to be taken out.
+ (delete-file-recursively ".hg")
+ #t))))
+
+;;; hg.scm ends here