summaryrefslogtreecommitdiff
path: root/guix/build/gnu-build-system.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-12-28 23:46:59 +0100
committerLudovic Courtès <ludo@gnu.org>2014-12-28 23:46:59 +0100
commitf05bdc9412135f34a1c417edc203c35cd005d0d5 (patch)
treed31aa1eb3c7e20a631c037f84416036c1e86c9f0 /guix/build/gnu-build-system.scm
parent2a8d44015ff2672b7a9a2ea5054b51a83b0e934b (diff)
downloadguix-patches-f05bdc9412135f34a1c417edc203c35cd005d0d5.tar
guix-patches-f05bdc9412135f34a1c417edc203c35cd005d0d5.tar.gz
gnu: Don't use --strip-all in cases where this is problematic.
This is a followup to 856ae5e. See <http://hydra.gnu.org/build/180506> for an example of build failure. * guix/build/gnu-build-system.scm (strip): Add #:archive-strip-flags parameter. Use it when (ar-file? path). * guix/build-system/gnu.scm (gnu-build): Add #:archive-strip-flags parameter and pass it down. * gnu/packages/commencement.scm (gcc-boot0)[arguments]: Add #:strip-flags. * gnu/packages/base.scm (glibc)[arguments]: Likewise.
Diffstat (limited to 'guix/build/gnu-build-system.scm')
-rw-r--r--guix/build/gnu-build-system.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/guix/build/gnu-build-system.scm b/guix/build/gnu-build-system.scm
index 11b43c521f..a985b1c715 100644
--- a/guix/build/gnu-build-system.scm
+++ b/guix/build/gnu-build-system.scm
@@ -298,6 +298,12 @@ makefiles."
(string-append target "-objcopy")
"objcopy"))
(strip-flags '("--strip-all"))
+
+ ;; Using '--strip-all' on .a file would remove the archive
+ ;; index, leading to "Archive has no index" errors when
+ ;; linking against them.
+ (archive-strip-flags '("--strip-debug"))
+
(strip-directories '("lib" "lib64" "libexec"
"bin" "sbin"))
#:allow-other-keys)
@@ -353,7 +359,10 @@ makefiles."
(or (not debug-output)
(make-debug-file path))
(zero? (apply system* strip-command
- (append strip-flags (list path))))
+ (append (if (ar-file? path)
+ archive-strip-flags
+ strip-flags)
+ (list path))))
(or (not debug-output)
(add-debug-link path))))
(const #t) ; down