summaryrefslogtreecommitdiff
path: root/guix/build/gnu-build-system.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-12-27 19:20:18 +0100
committerLudovic Courtès <ludo@gnu.org>2014-12-27 19:20:18 +0100
commit856ae5e6c71a1283a414d33e638051f95d3cce35 (patch)
treec60e443f50b50be2fb8bbb4e5768ace140c9d217 /guix/build/gnu-build-system.scm
parent9a224ac2e37482cb69c2803648bf3c66fbc6eee9 (diff)
downloadguix-patches-856ae5e6c71a1283a414d33e638051f95d3cce35.tar
guix-patches-856ae5e6c71a1283a414d33e638051f95d3cce35.tar.gz
build-system/gnu: Strip with '--strip-all' instead of '--strip-debug'.
This saves 19% on the 'bin' directory of Coreutils, and certainly helpful for things like Git's 'libexec' directory. * guix/build-system/gnu.scm (gnu-build): Change default value for #:strip-flags to '("--strip-all"). * guix/build/gnu-build-system.scm (strip): Ditto. * gnu/packages/linux.scm (linux-libre)[arguments]: Add #:strip-flags.
Diffstat (limited to 'guix/build/gnu-build-system.scm')
-rw-r--r--guix/build/gnu-build-system.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/guix/build/gnu-build-system.scm b/guix/build/gnu-build-system.scm
index 4cc755f3a6..d661736831 100644
--- a/guix/build/gnu-build-system.scm
+++ b/guix/build/gnu-build-system.scm
@@ -295,7 +295,7 @@ makefiles."
(objcopy-command (if target
(string-append target "-objcopy")
"objcopy"))
- (strip-flags '("--strip-debug"))
+ (strip-flags '("--strip-all"))
(strip-directories '("lib" "lib64" "libexec"
"bin" "sbin"))
#:allow-other-keys)