summaryrefslogtreecommitdiff
path: root/guix/build/download-nar.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-08-06 15:00:01 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-08-24 10:41:06 +0200
commite9f8a7e21579fd2833dfca6830e21f886a79a9ca (patch)
tree9d5c2c909f37a65d78c452894195a3a2318bda75 /guix/build/download-nar.scm
parentc6872990b51971922f3064cba54ab752fcdc1559 (diff)
downloadguix-patches-e9f8a7e21579fd2833dfca6830e21f886a79a9ca.tar
guix-patches-e9f8a7e21579fd2833dfca6830e21f886a79a9ca.tar.gz
Use guile-zlib extension in build-side code.
* Makefile.am (MODULES): Move guix/build/download-nar.scm to ... (MODULES_NOT_COMPILED): ... here. * guix/build/download-nar.scm: Use (zlib) instead of (guix zlib). * guix/cvs-download.scm (cvs-fetch): Do not stub (guix config) in imported modules list, instead add "guile-zlib" to the extension list. * guix/git-download.scm (git-fetch): Ditto. * guix/hg-download.scm (hg-fetch): Do not stub (guix config) in imported modules list, instead add "guile-zlib" to the extension list.
Diffstat (limited to 'guix/build/download-nar.scm')
-rw-r--r--guix/build/download-nar.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/guix/build/download-nar.scm b/guix/build/download-nar.scm
index 377e428341..867f3c10bb 100644
--- a/guix/build/download-nar.scm
+++ b/guix/build/download-nar.scm
@@ -20,7 +20,7 @@
#:use-module (guix build download)
#:use-module (guix build utils)
#:use-module ((guix serialization) #:hide (dump-port*))
- #:use-module (guix zlib)
+ #:autoload (zlib) (call-with-gzip-input-port)
#:use-module (guix progress)
#:use-module (web uri)
#:use-module (srfi srfi-11)