summaryrefslogtreecommitdiff
path: root/guix/build/cargo-build-system.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2017-04-14 12:12:56 +0200
committerLudovic Courtès <ludo@gnu.org>2017-04-14 12:29:20 +0200
commite60ee79040c8fd46796d7f6ad2e07c95dc9dcadb (patch)
treefd902f0cf8907e38aeeb36d185f4e7da14f08430 /guix/build/cargo-build-system.scm
parent11e2087e250150ccedd5309afd1e056295d77c46 (diff)
downloadguix-patches-e60ee79040c8fd46796d7f6ad2e07c95dc9dcadb.tar
guix-patches-e60ee79040c8fd46796d7f6ad2e07c95dc9dcadb.tar.gz
build-system/cargo: Remove store reference.
* guix/build/cargo-build-system.scm (generate-checksums): Remove store reference from comment. This comment was matching assert-no-store-file-names regexp in Makefile.am. Also, edit procedure docstring to precise that DIR-NAME is a store directory. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'guix/build/cargo-build-system.scm')
-rw-r--r--guix/build/cargo-build-system.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/guix/build/cargo-build-system.scm b/guix/build/cargo-build-system.scm
index f11d858749..139b40321f 100644
--- a/guix/build/cargo-build-system.scm
+++ b/guix/build/cargo-build-system.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 David Craven <david@craven.ch>
+;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -116,12 +117,12 @@ directory = '" port)
(close-pipe port)
result)))
-;; Example dir-name: "/gnu/store/hwlr49riz3la33m6in2n898ly045ylld-rust-rand-0.3.15".
(define (generate-checksums dir-name src-name)
- "Given DIR-NAME, checksum all the files in it one by one and put the
- result into the file \".cargo-checksum.json\" in the same directory.
- Also includes the checksum of an extra file SRC-NAME as if it was
- part of the directory DIR-NAME with name \"package\"."
+ "Given DIR-NAME, a store directory, checksum all the files in it one
+by one and put the result into the file \".cargo-checksum.json\" in
+the same directory. Also includes the checksum of an extra file
+SRC-NAME as if it was part of the directory DIR-NAME with name
+\"package\"."
(let* ((file-names (find-files dir-name "."))
(dir-prefix-name (string-append dir-name "/"))
(dir-prefix-name-len (string-length dir-prefix-name))