summaryrefslogtreecommitdiff
path: root/guix/build-system
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-04-05 19:54:29 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-07-17 04:10:28 +0200
commit3d3bc413b4288fbf45a61fb2136387878375ebef (patch)
tree03447ed4f43ce6044d9d5b8950b45fe50b0f52ba /guix/build-system
parent5654eef7e9d32e3a1981417d5db7de7b4f9f5391 (diff)
downloadguix-patches-3d3bc413b4288fbf45a61fb2136387878375ebef.tar
guix-patches-3d3bc413b4288fbf45a61fb2136387878375ebef.tar.gz
guix: java-utils: Add Maven-related phases.
* guix/build/maven/java.scm: New file. * guix/build/maven/plugin.scm: New file. * guix/build/maven/pom.scm: New file. * Makefile.am (MODULES): Add them. * guix/build-system/ant.scm (%ant-build-system-modules): Add them to the build side. * guix/build/java-utils.scm (generate-plugin.xml, install-pom-file) (install-from-pom): New procedures.
Diffstat (limited to 'guix/build-system')
-rw-r--r--guix/build-system/ant.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/guix/build-system/ant.scm b/guix/build-system/ant.scm
index b5626bd42d..1809d1f3d2 100644
--- a/guix/build-system/ant.scm
+++ b/guix/build-system/ant.scm
@@ -39,6 +39,9 @@
(define %ant-build-system-modules
;; Build-side modules imported by default.
`((guix build ant-build-system)
+ (guix build maven java)
+ (guix build maven plugin)
+ (guix build maven pom)
(guix build java-utils)
(guix build syscalls)
,@%gnu-build-system-modules))