summaryrefslogtreecommitdiff
path: root/guix/build-system/trivial.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-09-10 22:47:10 +0200
committerLudovic Courtès <ludo@gnu.org>2012-09-10 22:47:10 +0200
commitbe13fbfa83dd3e3c7a7a3d09f9c520940eb350d4 (patch)
tree0af29db18eee64b9f3e7e2f55dd98b7ef27d0c90 /guix/build-system/trivial.scm
parent3c0670e686b33b50f35811f1427bf0d3e1abce41 (diff)
downloadguix-patches-be13fbfa83dd3e3c7a7a3d09f9c520940eb350d4.tar
guix-patches-be13fbfa83dd3e3c7a7a3d09f9c520940eb350d4.tar.gz
Add (guix build-system trivial).
* guix/build-system/trivial.scm: New file. * Makefile.am (MODULES): Add it. * tests/packages.scm ("trivial"): New test. * guix/packages.scm (package-derivation): Allow SOURCE to be #f.
Diffstat (limited to 'guix/build-system/trivial.scm')
-rw-r--r--guix/build-system/trivial.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/guix/build-system/trivial.scm b/guix/build-system/trivial.scm
new file mode 100644
index 0000000000..1134ae988c
--- /dev/null
+++ b/guix/build-system/trivial.scm
@@ -0,0 +1,39 @@
+;;; Guix --- Nix package management from Guile. -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix build-system trivial)
+ #:use-module (guix store)
+ #:use-module (guix utils)
+ #:use-module (guix derivations)
+ #:use-module (guix build-system)
+ #:export (trivial-build-system))
+
+(define* (trivial-build store name source inputs
+ #:key outputs system builder (modules '()))
+ "Run build expression BUILDER, an expression, for SYSTEM. SOURCE is
+ignored."
+ (build-expression->derivation store name system builder inputs
+ #:outputs outputs
+ #:modules modules))
+
+(define trivial-build-system
+ (build-system (name 'trivial)
+ (description
+ "Trivial build system, to run arbitrary Scheme build expressions")
+ (build trivial-build)
+ (cross-build trivial-build)))