summaryrefslogtreecommitdiff
path: root/guix/build-system/texlive.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-10 22:30:54 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-10 22:43:09 +0100
commitd4d9a1ece0dbf0bc65cc98e971e88a1406bb9c27 (patch)
tree55546c177c890ac5e3c8c2872f006a0690115972 /guix/build-system/texlive.scm
parentc954fe6622660f1511ced2be955c35acfb8b124a (diff)
downloadguix-patches-d4d9a1ece0dbf0bc65cc98e971e88a1406bb9c27.tar
guix-patches-d4d9a1ece0dbf0bc65cc98e971e88a1406bb9c27.tar.gz
gnu: Update texlive packages.
* guix/build-system/texlive.scm (%texlive-tag, %texlive-revision): Update to texlive-2018.2, revision 49435. * gnu/packages/tex.scm (texlive-dvips, texlive-generic-unicode-data, texlive-generic-dehyph-exptl, texlive-generic-hyph-utf8, texlive-fontname, texlive-fonts-cm, texlive-tex-plain, texlive-latex-base, texlive-latex-graphics, texlive-latex-graphics, texlive-latex-oberdiek, texlive-latex-tools, texlive-latex-l3kernel, texlive-latex-l3packages, texlive-latex-fontspec, texlive-latex-amsmath, texlive-latex-amscls, texlive-latex-babel, texlive-latex-cyrillic, texlive-latex-eqparbox, texlive-latex-ifplatform, texlive-latex-etoolbox, texlive-latex-galois, texlive-latex-polyglossia, texlive-tex-texinfo, texlive-latex-changebar, texlive-latex-fancyhdr, texlive-latex-overpic, texlive-latex-parskip, texlive-metapost, texlive-latex-ucs, texlive-generic-pdftex, texlive-latex-media9, texlive-latex-ocgx2, texlive-latex-koma-script, texlive-generic-listofitems, texlive-bibtex, texlive-context-base): Update hashes. (texlive-latex-fontspec)[arguments]: Remove custom build target. (texlive-latex-dinbrief)[arguments]: Add build phase "fix-encoding-error". (texlive-latex-xkeyval): New variable. (texlive-latex-pstool)[source]: Fetch from new location. [build-system]: Use trivial-build-system. [arguments]: Write simple builder. [propagated-inputs]: Add texlive-latex-l3kernel, texlive-latex-tools, and texlive-latex-xkeyval. [synopsis]: Fix typo.
Diffstat (limited to 'guix/build-system/texlive.scm')
-rw-r--r--guix/build-system/texlive.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/guix/build-system/texlive.scm b/guix/build-system/texlive.scm
index 80882b144b..b6a86a1c62 100644
--- a/guix/build-system/texlive.scm
+++ b/guix/build-system/texlive.scm
@@ -39,9 +39,10 @@
;;
;; Code:
-;; These variables specify the SVN tag and the matching SVN revision.
-(define %texlive-tag "texlive-2017.1")
-(define %texlive-revision 44591)
+;; These variables specify the SVN tag and the matching SVN revision. They
+;; are taken from https://www.tug.org/svn/texlive/tags/
+(define %texlive-tag "texlive-2018.2")
+(define %texlive-revision 49435)
(define (texlive-ref component id)
"Return a <svn-reference> object for the package ID, which is part of the