summaryrefslogtreecommitdiff
path: root/guix/build-system/python.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-11-20 23:51:26 +0100
committerLudovic Courtès <ludo@gnu.org>2013-11-20 23:51:26 +0100
commitedae5b3d50692c25e29fe65fdc14ae3ccdce884d (patch)
treeec257af3a922fd96bda8b8b16c00c8d0beaf445a /guix/build-system/python.scm
parent1dba64079c5aaa1fb40e4b1d989f1f06efd6cb63 (diff)
parente3aaefe71bd26daf6fdbfd0634f68a90985e059b (diff)
downloadguix-patches-edae5b3d50692c25e29fe65fdc14ae3ccdce884d.tar
guix-patches-edae5b3d50692c25e29fe65fdc14ae3ccdce884d.tar.gz
Merge branch 'master' into core-updates
Conflicts: guix/packages.scm
Diffstat (limited to 'guix/build-system/python.scm')
-rw-r--r--guix/build-system/python.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/guix/build-system/python.scm b/guix/build-system/python.scm
index 32b1f36a94..a97135fe0c 100644
--- a/guix/build-system/python.scm
+++ b/guix/build-system/python.scm
@@ -96,6 +96,7 @@ prepended to the name."
#:key
(python (default-python))
(tests? #t)
+ (test-target "test")
(configure-flags ''())
(phases '(@ (guix build python-build-system)
%standard-phases))
@@ -124,7 +125,7 @@ provides a 'setup.py' file as its build system."
source)
#:configure-flags ,configure-flags
#:system ,system
- #:test-target "test"
+ #:test-target ,test-target
#:tests? ,tests?
#:phases ,phases
#:outputs %outputs