summaryrefslogtreecommitdiff
path: root/guix/build-system/python.scm
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-04-06 16:48:09 +0200
committerGuix Patches Tester <>2020-04-06 15:50:06 +0100
commiteda5ec4429c9947e078a03923319718f50e9e0a1 (patch)
treedba08ff212fe091e3a1664617587f142f18a4ffd /guix/build-system/python.scm
parent1ba85062c23051bfab07043ba5b9fa58fc4c9465 (diff)
downloadguix-patches-eda5ec4429c9947e078a03923319718f50e9e0a1.tar
guix-patches-eda5ec4429c9947e078a03923319718f50e9e0a1.tar.gz
build-system/python: Add a #:python-output argument.
This simplifies packages that ship Python bindings in a separate output. * guix/build-system/python.scm (python-build): Add the argument, pass it build-side. * guix/build/python-build-system.scm (site-packages): Add an #:output argument. (add-installed-pythonpath): Likewise. (install): Use the #:python-output argument. (wrap): Likewise. (rename-pth-file): Likewise. Use the site-packages procedure.
Diffstat (limited to 'guix/build-system/python.scm')
-rw-r--r--guix/build-system/python.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/guix/build-system/python.scm b/guix/build-system/python.scm
index e39c06528e..34cc487c8c 100644
--- a/guix/build-system/python.scm
+++ b/guix/build-system/python.scm
@@ -170,6 +170,7 @@ pre-defined variants."
(phases '(@ (guix build python-build-system)
%standard-phases))
(outputs '("out"))
+ (python-output "out")
(search-paths '())
(system (%current-system))
(guile #f)
@@ -196,6 +197,7 @@ provides a 'setup.py' file as its build system."
#:use-setuptools? ,use-setuptools?
#:phases ,phases
#:outputs %outputs
+ #:python-output ,python-output
#:search-paths ',(map search-path-specification->sexp
search-paths)
#:inputs %build-inputs)))