summaryrefslogtreecommitdiff
path: root/guix/build-system/python.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-09-04 18:04:15 +0200
committerAndreas Enge <andreas@enge.fr>2013-09-04 18:07:55 +0200
commit3df47231e6c632aadcd7b103bb5b399a8d29772d (patch)
tree423260305ff37b1b742399d3c1021a0c472a37f0 /guix/build-system/python.scm
parentee3e314bb7ba376c7e8c95c3da1f64ba07d57847 (diff)
downloadguix-patches-3df47231e6c632aadcd7b103bb5b399a8d29772d.tar
guix-patches-3df47231e6c632aadcd7b103bb5b399a8d29772d.tar.gz
guix: python: Switch to python-wrapper as the default version for the python
build system (switches to Python 3) and compute python-version instead of passing it as a parameter. * guix/build-system/python.scm (default-python): Switch to python-wrapper. * guix/build-system/python.scm (python-build): Drop parameter #:python-version. * guix/build/python-build-system.scm (wrap): Compute python version from input.
Diffstat (limited to 'guix/build-system/python.scm')
-rw-r--r--guix/build-system/python.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/guix/build-system/python.scm b/guix/build-system/python.scm
index b60adb182f..7ac93b296b 100644
--- a/guix/build-system/python.scm
+++ b/guix/build-system/python.scm
@@ -39,13 +39,11 @@
"Return the default Python package."
;; Lazily resolve the binding to avoid a circular dependency.
(let ((python (resolve-interface '(gnu packages python))))
- (module-ref python 'python)))
+ (module-ref python 'python-wrapper)))
(define* (python-build store name source inputs
#:key
(python (default-python))
- (python-version
- (string-take (package-version (default-python)) 3))
(tests? #t)
(configure-flags ''())
(phases '(@ (guix build python-build-system)
@@ -62,6 +60,7 @@
(guix build utils))))
"Build SOURCE using PYTHON, and with INPUTS. This assumes that SOURCE
provides a 'setup.py' file as its build system."
+
(define python-search-paths
(append (package-native-search-paths python)
(standard-search-paths)))
@@ -78,7 +77,6 @@ provides a 'setup.py' file as its build system."
#:test-target "test"
#:tests? ,tests?
#:outputs %outputs
- #:python-version ,python-version
#:search-paths ',(map search-path-specification->sexp
(append python-search-paths
search-paths))